diff configure.in @ 110:fe104dbd9147 r20-1b7

Import from CVS: tag r20-1b7
author cvs
date Mon, 13 Aug 2007 09:19:45 +0200
parents 360340f9fd5f
children 48d667d6f17f
line wrap: on
line diff
--- a/configure.in	Mon Aug 13 09:18:41 2007 +0200
+++ b/configure.in	Mon Aug 13 09:19:45 2007 +0200
@@ -300,6 +300,8 @@
 --wnn-libraries=DIR	Search for WNN libraries in DIR.
 --with-i18n3		Compile with I18N level 3 (support for message
 			translation).  This doesn't currently work.
+--canna-includes=DIR 	Search for Canna header files in DIR.
+--canna-libraries=DIR	Search for Canna libraries in DIR.
 
 
 Debugging options:
@@ -465,6 +467,8 @@
 	x_libraries	| \
         wnn_includes    | \
         wnn_libraries   | \
+        canna_includes    | \
+        canna_libraries   | \
 	site_includes	| \
 	site_libraries	| \
 	site_runtime_libraries  )
@@ -1354,7 +1358,8 @@
       i[3-9]86-*-sunos4*  ) opsys=sunos4-0	;;
       *-sunos4.0*	  ) opsys=sunos4-0	;;
       *-sunos4.1.2*	  ) opsys=sunos4-1-2	;;
-      *-sunos4.1.[3-9]*	  ) opsys=sunos4-1-3	;;
+      *-sunos4.1.3*	  ) opsys=sunos4-1-3	;;
+      *-sunos4.1.[4-9]*	  ) opsys=sunos4-1-4	;;
       *-sunos4* | *-sunos ) opsys=sunos4-1	;;
 
       *-solaris2.3*	  ) opsys=sol2-3	;;
@@ -1445,7 +1450,7 @@
       *-linux* )		opsys=linux ;;
       *-sco3.2v4* )		opsys=sco4 ; NON_GNU_CPP=/lib/cpp  ;;
       *-bsd386* | *-bsdi1* )	opsys=bsd386 ;;
-      *-bsdi3* )		opsys=bsdos2-1 ;;
+      *-bsdi3* )		opsys=bsdos3 ;;
       *-bsdi2.1* )		opsys=bsdos2-1 ;;
       *-bsdi2* )		opsys=bsdos2 ;;
       *-sco3.2v5* )		opsys=sco5 ; 
@@ -2688,6 +2693,26 @@
   done
 fi
 
+#
+# set defaults for finding Canna includes and libs
+#
+if test "${with_canna}" = "yes" ; then
+  for arg in "-I${canna_includes}" "-I/usr/X11R6/include"
+  do
+    if test -f `echo "${arg}/canna/RK.h" | sed 's/^\-I//'` ; then
+      C_SWITCH_SITE="${C_SWITCH_SITE} ${arg}"
+      canna_includes=${arg}
+    fi
+  done
+  for arg in "-L${canna_libraries}" "-I/usr/X11R6/lib"
+  do
+    if test -f `echo "${arg}/libcanna.a" | sed 's/^\-L//'` ; then
+      LD_SWITCH_SITE="${LD_SWITCH_SITE} ${arg}"
+      canna_libraries=${arg}
+    fi
+  done
+fi
+
 # If netdb.h doesn't declare h_errno, we must declare it by hand.
 AC_COMPILE_CHECK(declaration of h_errno in netdb.h,
 	[#include <netdb.h>],