diff configure.in @ 557:f486da5f1a3b

[xemacs-hg @ 2001-05-22 06:49:12 by martinb] final part of MacOS X port
author martinb
date Tue, 22 May 2001 06:49:43 +0000
parents 5c6dc7d576ad
children 5101772788b2
line wrap: on
line diff
--- a/configure.in	Tue May 22 06:03:58 2001 +0000
+++ b/configure.in	Tue May 22 06:49:43 2001 +0000
@@ -1769,7 +1769,9 @@
 CPP_to_sh(LD_SWITCH_MACHINE,  ld_switch_machine)
 CPP_to_sh(LD_SWITCH_SYSTEM,   ld_switch_system)
 
-CPP_to_sh(UNEXEC, unexec, unexec.o)
+CPP_to_sh(UNEXEC, unexec)
+
+CPP_to_sh(SYSTEM_TYPE, system_type)
 
 CPP_to_sh(LD_SWITCH_SHARED, ld_switch_shared, -c)
 
@@ -1831,6 +1833,17 @@
 
 rm $tempcname
 
+dnl s&m files shouldn't be required to define anything, or even to exist.
+dnl So we default SYSTEM_TYPE to the obvious documented standard, `uname -s`,
+dnl appropriately emacsulated.
+test -z "$system_type" && \
+  AC_DEFINE_UNQUOTED(SYSTEM_TYPE,"`uname -s | tr ABCDEFGHIJKLMNOPQRSTUVWXYZ abcdefghijklmnopqrstuvwxyz`")
+
+dnl If the s&m files don't define a system-specific dumper, simply use pdump.
+dnl Sometime in the future, we'll remove all definitions of UNEXEC
+dnl from all the s&m files.
+test -z "$unexec" && pdump=yes
+
 if test "$pdump" = "yes"; then
   ordinary_link="yes"
   ld="${ordinary_ld}"