diff configure.ac @ 5724:ede80ef92a74

Make soft links in src for module source files, if built in to the executable. This ensures that those files are built with the same compiler flags as all other source files. See these xemacs-beta messages: <CAHCOHQn+q=Xuwq+y68dvqi7afAP9f-TdB7=8YiZ8VYO816sjHg@mail.gmail.com> <f5by5ejqiyk.fsf@calexico.inf.ed.ac.uk>
author Jerry James <james@xemacs.org>
date Sat, 02 Mar 2013 14:32:37 -0700
parents dede3f658f8e
children 1af0602ff9a2
line wrap: on
line diff
--- a/configure.ac	Fri Feb 22 16:18:37 2013 +0100
+++ b/configure.ac	Sat Mar 02 14:32:37 2013 -0700
@@ -3613,10 +3613,14 @@
   save_LIBS="$LIBS" LIBS="$LIBS $ldap_libs"
   AC_CHECK_FUNCS(ldap_set_option ldap_get_lderrno ldap_result2error ldap_parse_result)
   LIBS="$save_LIBS"
-  XE_APPEND(modules/ldap, MAKE_SUBDIR)
-  need_modules_common=yes
   if test "$with_modules" = "yes"; then
+    XE_APPEND(modules/ldap, MAKE_SUBDIR)
     XE_APPEND(modules/ldap, INSTALL_ARCH_DEP_SUBDIR)
+  else
+    mkdir src
+    for fil in eldap.c eldap.h; do
+      ${LN_S} "$srcdir/modules/ldap/$fil" "src/$fil"
+    done
   fi
 fi
 AC_SUBST(ldap_libs)
@@ -3664,10 +3668,14 @@
                  AC_DEFINE(HAVE_POSTGRESQLV7)], [:], $extra_libs)
     AC_DEFINE_UNQUOTED(LIBPQ_FE_H_FILE, "$libpq_fe_h_file")
     XE_PREPEND([$pq_libs], postgresql_libs)
-    XE_APPEND(modules/postgresql, MAKE_SUBDIR)
-    need_modules_common=yes
     if test "$with_modules" = "yes"; then
+      XE_APPEND(modules/postgresql, MAKE_SUBDIR)
       XE_APPEND(modules/postgresql, INSTALL_ARCH_DEP_SUBDIR)
+    else
+      mkdir src
+      for fil in postgresql.c postgresql.h; do
+        ${LN_S} "$srcdir/modules/postgresql/$fil" "src/$fil"
+      done
     fi
   elif test "$with_postgresql" = "yes"; then
     XE_DIE("Required PostgreSQL support cannot be provided.  Check --with-site-prefixes.")
@@ -4340,10 +4348,12 @@
   if test "$have_canna" = "yes"; then
     AC_DEFINE(HAVE_CANNA)
     test -n "$canna_wchar_aware" && AC_DEFINE(CANNA_NEW_WCHAR_AWARE)
-    XE_APPEND(modules/canna, MAKE_SUBDIR)
-    need_modules_common=yes
     if test "$with_modules" = "yes"; then
+      XE_APPEND(modules/canna, MAKE_SUBDIR)
       XE_APPEND(modules/canna, INSTALL_ARCH_DEP_SUBDIR)
+    else
+      mkdir src
+      ${LN_S} "$srcdir/modules/canna/canna_api.c" "src/canna_api.c"
     fi
     XE_PREPEND(-lcanna -lRKC, canna_libs)
   elif test "$with_canna" != "no"; then