diff configure.ac @ 4419:eb82fbb675ea

Use Mercurial changeset hash to identify build version. 2008-01-25 Michael Sperber <mike@xemacs.org> * Makefile.in.in: * configure.ac: * version.sh.in: Use Mercurial tip hash to identify version instead of old CVS method. 2008-01-25 Michael Sperber <mike@xemacs.org> * build-report.el (build-report-version-file-regexp): Adjust to handle Mercurial hash. 2008-01-25 Michael Sperber <mike@xemacs.org> * xemacs.mak (version.sh): Generate version.sh via Mercurial. 2008-01-25 Michael Sperber <mike@xemacs.org> * emacs.c (vars_of_emacs): Zap mention of CVS.
author Mike Sperber <sperber@deinprogramm.de>
date Thu, 07 Feb 2008 10:03:49 +0100
parents 2f000e022a8b
children 42711a251efd
line wrap: on
line diff
--- a/configure.ac	Mon Feb 04 21:41:27 2008 -0700
+++ b/configure.ac	Thu Feb 07 10:03:49 2008 +0100
@@ -1176,6 +1176,11 @@
 dnl ----------------------------------------
 dnl Find out which version of XEmacs this is
 dnl ----------------------------------------
+dnl This should be the same code as in Makefile.in.in
+cp "$srcdir/version.sh.in" "$srcdir/version.sh"
+if test -d "$srcdir/.hg"; then
+    (cd "$srcdir"; hg identify | cut -d " " -f 1 >> version.sh)
+fi
 . "$srcdir/version.sh" || exit 1;
 dnl Must do the following first to determine verbosity for AC_DEFINE
 if test -n "$emacs_is_beta"; then beta=yes; else beta=no; fi