diff configure.in @ 551:e9a3f8b4de53

[xemacs-hg @ 2001-05-21 05:26:06 by martinb] realloc() handling on sunos4; remove lwlib-config kludge
author martinb
date Mon, 21 May 2001 05:26:51 +0000
parents 836d476763d0
children 5c6dc7d576ad
line wrap: on
line diff
--- a/configure.in	Mon May 21 02:15:12 2001 +0000
+++ b/configure.in	Mon May 21 05:26:51 2001 +0000
@@ -2304,19 +2304,6 @@
   fi
 fi
 
-define([XE_REALLOC_NULLPTR_BUG],[
-AC_MSG_CHECKING(whether realloc accepts null pointers)
-AC_TRY_RUN([int main ()
-  { char *x = 0;
-    x = realloc (x, 16); if (!x) return 1; x[15] = 'y';
-    x = realloc (x, 64); if (!x) return 1; x[63] = 'z';
-    return 0;
-  }],
- [AC_MSG_RESULT(yes)], 
- [AC_MSG_RESULT(no); AC_DEFINE(REALLOC_NULLPTR_BUG) ])])
-
-XE_REALLOC_NULLPTR_BUG
-
 dnl #### mcheck is broken in all versions of Linux libc and glibc.
 dnl Try this again when 2.1 hits the streets.
 dnl Avoid using free-hook.c if support exists for malloc debugging in libc