diff configure.ac @ 5765:e88d026f3917

Include uname and configure arguments in stdout.
author Stephen J. Turnbull <stephen@xemacs.org>
date Sun, 15 Sep 2013 23:50:20 +0900
parents a9fd35f939a5
children 4e69b24a2301
line wrap: on
line diff
--- a/configure.ac	Sun Sep 15 23:50:20 2013 +0900
+++ b/configure.ac	Sun Sep 15 23:50:20 2013 +0900
@@ -5660,6 +5660,20 @@
 dnl #### We should tag this as the _build_ environment.
 dnl Before doing that, though, must check if tools care about line 1.
 
+if test ! -z ${emacs_beta_version} ; then
+  if test -z "${emacs_is_beta}" ; then
+	xemacs_betaname=".${emacs_beta_version}"
+  else
+	xemacs_betaname="-b${emacs_beta_version}"
+  fi
+else
+  xemacs_betaname=""
+fi
+
+echo ""
+: > Installation
+
+dnl Start stdout redirection to '| tee -a Installation'
 (
 dnl /etc/osversion is on SONY NEWS-OS
 if test -f /etc/osversion; then dnl SONY NEWS-OS
@@ -5669,20 +5683,7 @@
 fi
 echo ""
 echo "$progname $ac_configure_args"
-) > Installation
-
-if test ! -z ${emacs_beta_version} ; then
-  if test -z "${emacs_is_beta}" ; then
-	xemacs_betaname=".${emacs_beta_version}"
-  else
-	xemacs_betaname="-b${emacs_beta_version}"
-  fi
-else
-  xemacs_betaname=""
-fi
-
-dnl Start stdout redirection to '| tee -a Installation'
-(
+
 echo "
 
 XEmacs ${emacs_major_version}.${emacs_minor_version}${xemacs_betaname} \"$xemacs_codename\" $xemacs_extra_name configured for \`$ac_cv_build'."