diff configure.in @ 2300:e2fdc9035c5b

[xemacs-hg @ 2004-09-22 11:40:40 by malcolmp] Unused parameter and variables warnings apply to GCC 3 or greater.
author malcolmp
date Wed, 22 Sep 2004 11:41:02 +0000
parents 04bc9d2f42c7
children e219f63b9c24
line wrap: on
line diff
--- a/configure.in	Wed Sep 22 03:04:44 2004 +0000
+++ b/configure.in	Wed Sep 22 11:41:02 2004 +0000
@@ -2055,13 +2055,12 @@
     cflags_warning="-qinfo"
   elif test "$GCC" = "yes"; then
     cflags_warning="-Wall -Wno-switch -Winline -Wmissing-prototypes"
-    cflags_warning="$cflags_warning -Wunused-parameter -Wunused-variable"
 
     dnl Yuck, bad compares have been worth at least 3 crashes!
     cflags_warning="$cflags_warning -Wsign-compare"
     cflags_warning="$cflags_warning -Wundef -Wstrict-prototypes"
     if test "$__GCC3" = "yes"; then
-      cflags_warning="$cflags_warning -Wpacked"
+      cflags_warning="$cflags_warning -Wpacked -Wunused-parameter -Wunused-variable"
     fi
     dnl glibc is intentionally not `-Wpointer-arith'-clean.
     dnl Ulrich Drepper has rejected patches to fix the glibc header files.