diff configure.ac @ 2741:d5863780dbef

[xemacs-hg @ 2005-04-22 12:45:22 by malcolmp] configure.ac: Make srcdir absolute before calling AC_CONFIG_AUX_DIR_DEFAULT, include X headers for shape.h, terminate checking lines when testing for dynamic libraries.
author malcolmp
date Fri, 22 Apr 2005 12:45:41 +0000
parents 6fa9919a9a0b
children ac63ab256048
line wrap: on
line diff
--- a/configure.ac	Thu Apr 21 21:51:55 2005 +0000
+++ b/configure.ac	Fri Apr 22 12:45:41 2005 +0000
@@ -964,9 +964,6 @@
 AC_SUBST(statedir,$with_statedir)
 
 dnl -------------------------------------------------------------------------
-AC_CONFIG_AUX_DIR_DEFAULT
-AC_CANONICAL_BUILD
-dnl -------------------------------------------------------------------------
 
 AC_PROG_LN_S
 
@@ -1019,6 +1016,11 @@
 vpath %.in $(srcdir)'
 fi
 
+dnl -------------------------------------------------------------------------
+AC_CONFIG_AUX_DIR_DEFAULT
+AC_CANONICAL_BUILD
+dnl -------------------------------------------------------------------------
+
 dnl ----------------------------------------
 dnl Find out which version of XEmacs this is
 dnl ----------------------------------------
@@ -3359,7 +3361,11 @@
 if test "$with_x11" = "yes"; then
   AC_CHECK_HEADER(X11/extensions/shape.h, [
    AC_DEFINE(HAVE_BALLOON_HELP)
-   ])
+   ],[],
+[
+#include <X11/Xlib.h>
+#include <X11/Xutil.h>
+])
 fi
 
 dnl FSF 19.29 has some bitmapdir stuff here.
@@ -3430,16 +3436,19 @@
       AC_CHECK_HEADER(dlfcn.h, [
 	AC_MSG_CHECKING([for dlopen in -lc])
 	AC_TRY_LINK([#include <dlfcn.h>],dnl
-	 [dlopen ("", 0);], [ have_dl=yes ], [
+	 [dlopen ("", 0);], [ have_dl=yes ; AC_MSG_RESULT($have_dl)], [
+	  AC_MSG_RESULT([no])
 	  AC_MSG_CHECKING([for dlopen in -ldl])
 	  ac_save_LIBS="$LIBS"
 	  LIBS="$LIBS -ldl"
 	  AC_TRY_LINK([#include <dlfcn.h>],dnl
-	   [dlopen ("", 0);], [ have_dl=yes ], [
+	   [dlopen ("", 0);], [ have_dl=yes; AC_MSG_RESULT($have_dl)], [
+	    AC_MSG_RESULT([no])
 	    AC_MSG_CHECKING([for dlopen in -lsvld])
 	    LIBS="$ac_save_LIBS -lsvld"
 	    AC_TRY_LINK([#include <dlfcn.h>],dnl
-	     [dlopen ("", 0);], [ have_dl=yes ], [LIBS="$ac_save_LIBS"])])])])
+	     [dlopen ("", 0);], [ have_dl=yes; AC_MSG_RESULT($have_dl) ],
+	     [LIBS="$ac_save_LIBS" ; AC_MSG_RESULT([no])])])])])
       if test "$have_dl" = "yes"; then
 	AC_DEFINE(HAVE_DLOPEN)
       else
@@ -3447,12 +3456,14 @@
 	AC_CHECK_HEADER(dl.h, [
 	  AC_MSG_CHECKING([for shl_load in -lc])
 	  AC_TRY_LINK([#include <dl.h>],dnl
-	   [shl_load ("", 0, 0);], [have_dl=yes], [
+	   [shl_load ("", 0, 0);], [have_dl=yes; AC_MSG_RESULT($have_dl)], [
+	    AC_MSG_RESULT([no])
 	    AC_MSG_CHECKING([for shl_load in -ldl])
 	    ac_save_LIBS="$LIBS"
 	    LIBS="$LIBS -ldld"
 	    AC_TRY_LINK([#include <dl.h>],dnl
-	     [shl_load ("", 0, 0);], [have_dl=yes], [LIBS="$ac_save_LIBS"])])])
+	     [shl_load ("", 0, 0);], [have_dl=yes],
+	     [LIBS="$ac_save_LIBS"; AC_MSG_RESULT([no])])])])
 	if test "$have_dl" = "yes"; then
 	  AC_DEFINE(HAVE_SHL_LOAD) 
 	else
@@ -3463,6 +3474,7 @@
 	    LIBS="$LIBS -lltdl"
 	    AC_TRY_LINK([#include <ltdl.h>],dnl
 	     [lt_dlinit ();], [have_dl=yes], [LIBS="$ac_save_LIBS"])])
+	  AC_MSG_RESULT($have_dl)
 	  if test "$have_dl" = "yes"; then
 	    AC_DEFINE(HAVE_LTDL)
 	  fi