diff configure.in @ 1651:d3af5b868526

[xemacs-hg @ 2003-08-28 15:45:20 by james] The usual second commit for the toplevel due to unknown brain damage.
author james
date Thu, 28 Aug 2003 15:45:30 +0000
parents baca156a450b
children 6265c9c31f53
line wrap: on
line diff
--- a/configure.in	Thu Aug 28 15:44:30 2003 +0000
+++ b/configure.in	Thu Aug 28 15:45:30 2003 +0000
@@ -3184,6 +3184,16 @@
 test -n "$xemacs_compiler" && XEMACS_CC="$xemacs_compiler"
 : ${XEMACS_CC:="$CC"}
 
+dnl If g++ is used, we have to explicitly link modules with -lstdc++ on Cygwin
+dnl to avoid undefined symbol errors.  This will never hurt, so just do it on
+dnl all platforms in case others have the same brain damage.
+if test "$xemacs_compiler" = "g++"; then
+  LIBSTDCPP=-lstdc++
+else
+  LIBSTDCPP=
+fi
+AC_SUBST(LIBSTDCPP)
+
 dnl Autodetect dll support
 dnl This must come before the detection code for anything that is in a module
 if test "$with_modules" != "no"; then