diff configure.ac @ 5598:bccc91a65536

Fix .gdbinit and .dbxrc when using the new garbage collector. ChangeLog: 2011-11-21 Marcus Crestani <crestani@informatik.uni-tuebingen.de> * configure.ac: Fix creation of etc/dbxrc and src/.dbxrc; only try to create Makefile when Makefile.in is there. * configure: Regenerate. src/ChangeLog: 2011-11-21 Marcus Crestani <crestani@informatik.uni-tuebingen.de> * .gdbinit.in.in: There is no lrecord_type_lcrecord_list when using the new garbage collector; print $lrecord_type when Lisp Object type is unknown to pobj. etc/ChangeLog: 2011-11-21 Marcus Crestani <crestani@informatik.uni-tuebingen.de> * dbxrc.in: There is no lrecord_type_lcrecord_list when using the new garbage collector; print $lrecord_type when Lisp Object type is unknown to pobj.
author Marcus Crestani <crestani@informatik.uni-tuebingen.de>
date Mon, 21 Nov 2011 10:28:31 +0100
parents 86d6adeb1cf4
children 3e5d5e8e4bb7
line wrap: on
line diff
--- a/configure.ac	Tue Nov 15 20:19:20 2011 -0500
+++ b/configure.ac	Mon Nov 21 10:28:31 2011 +0100
@@ -5377,8 +5377,8 @@
 
 dnl Create a .dbxrc useful for debugging XEmacs
 if test -f "$srcdir/etc/dbxrc.in"; then
-  test "$verbose" = "yes" && echo "creating src/.dbxrc.in"
-  echo ". $srcdir/etc/dbxrc.in" > "src/.dbxrc.in"
+  test "$verbose" = "yes" && echo "creating src/.dbxrc"
+  echo ". $srcdir/etc/dbxrc" > "$srcdir/src/.dbxrc"
 fi
 
 dnl Create a useful TAGS file
@@ -6009,6 +6009,9 @@
     mv -f Makefile.new $2
 ])dnl CPP_MAKEFILE
 
+dnl for creation of /etc/dbxrc
+XE_APPEND(etc, MAKE_SUBDIR)
+
 AC_CONFIG_COMMANDS([default],
 [for dir in . $MAKE_SUBDIR; do
   (
@@ -6017,17 +6020,19 @@
 dnl Create a GNUmakefile and Makefile from Makefile.in.
 dnl Create xemacs.def from xemacs.def.in in the same fashion,
 dnl if it exists (i.e. in the src/ directory).  Ditto for the
-dnl debugger init files (in the src/ directory).
-    MAKE_JUNK_C(Makefile.in)
-    CPP_MAKEFILE(,Makefile)
-    CPP_MAKEFILE(-DUSE_GNU_MAKE,GNUmakefile)
+dnl debugger init files (in the src/ and etc/ directories).
+    if test -r "Makefile.in"; then
+      MAKE_JUNK_C(Makefile.in)
+      CPP_MAKEFILE(,Makefile)
+      CPP_MAKEFILE(-DUSE_GNU_MAKE,GNUmakefile)
+    fi
     if test -r ".gdbinit.in"; then
       MAKE_JUNK_C(.gdbinit.in)
       CPP_MAKEFILE(,.gdbinit)
     fi
-    if test -r ".dbxrc.in"; then
-      MAKE_JUNK_C(.dbxrc.in)
-      CPP_MAKEFILE(,.dbxrc)
+    if test -r "dbxrc.in"; then
+      MAKE_JUNK_C(dbxrc.in)
+      CPP_MAKEFILE(,dbxrc)
     fi
     if test -r "xemacs.def.in"; then
 dnl #### We should be using MAKE_JUNK_C instead of the next two lines.