diff configure.in @ 1633:baca156a450b

[xemacs-hg @ 2003-08-19 02:11:46 by james] Make modules build and run on Cygwin and MinGW. This is the second commit to get the toplevel files that were not committed the first time.
author james
date Tue, 19 Aug 2003 02:11:49 +0000
parents d968d4073031
children d3af5b868526
line wrap: on
line diff
--- a/configure.in	Tue Aug 19 02:07:16 2003 +0000
+++ b/configure.in	Tue Aug 19 02:11:49 2003 +0000
@@ -5343,7 +5343,7 @@
   esac
   XE_APPEND($file, ac_output_files)
 done
-ac_output_files="$ac_output_files src/paths.h lib-src/config.values"
+ac_output_files="$ac_output_files src/paths.h src/xemacs.def.in lib-src/config.values"
 test "$with_modules" = "yes" && XE_APPEND(lib-src/ellcc.h, ac_output_files)
 
 AC_OUTPUT($ac_output_files,
@@ -5395,6 +5395,10 @@
 
     CPP_MAKEFILE(,Makefile)
     CPP_MAKEFILE(-DUSE_GNU_MAKE,GNUmakefile)
+    if test -e "xemacs.def.in"; then
+      cp -f xemacs.def.in junk.c
+      CPP_MAKEFILE(,xemacs.def)
+    fi
 changequote([,])dnl
     rm -f junk.c
   )