diff configure.in @ 72:b9518feda344 r20-0b31

Import from CVS: tag r20-0b31
author cvs
date Mon, 13 Aug 2007 09:03:46 +0200
parents 131b0175ea99
children 54cc21c15cbb
line wrap: on
line diff
--- a/configure.in	Mon Aug 13 09:03:07 2007 +0200
+++ b/configure.in	Mon Aug 13 09:03:46 2007 +0200
@@ -1130,11 +1130,11 @@
 
     case "${canonical}" in
       *-hp-hpux7*     )  opsys=hpux      ;;
-      *-hp-hpux8shr*  )  opsys=hpux8shr  ;;
+      *-hp-hpux8shr*  )  opsys=hpux8-shr  ;;
       *-hp-hpux8*     )  opsys=hpux8     ;;
-      *-hp-hpux9shr*  )  opsys=hpux9shr  ;;
+      *-hp-hpux9shr*  )  opsys=hpux9-shr  ;;
       *-hp-hpux9*     )  opsys=hpux9     ;;
-      *-hp-hpux10shr* )  opsys=hpux10shr ;;
+      *-hp-hpux10shr* )  opsys=hpux10-shr ;;
       *-hp-hpux10*    )  opsys=hpux10    ;;
       * )
         case "`uname -r`" in
@@ -2554,7 +2554,7 @@
 
 test "${with_menubars}"   != "no"    && AC_DEFINE(HAVE_MENUBARS)
 test "${with_scrollbars}" != "no"    && AC_DEFINE(HAVE_SCROLLBARS)
-test "${with_scrollbars}" != "no"    && AC_DEFINE(HAVE_DIALOGS)
+test "${with_dialogs}"    != "no"    && AC_DEFINE(HAVE_DIALOGS)
 
 test "${with_menubars}"   = "lucid"  && AC_DEFINE(LWLIB_MENUBARS_LUCID)
 test "${with_menubars}"   = "motif"  && AC_DEFINE(LWLIB_MENUBARS_MOTIF)
@@ -2714,7 +2714,7 @@
 # # On HPUX 9.01, -lm does not contain logb, so check for sqrt.
 # A C_CHECK_LIB(m, sqrt)
 
-AC_HAVE_FUNCS(acosh asinh atanh cbrt closedir dup2 eaccess fmod fpathconf frexp ftime gethostname getpagesize gettimeofday getwd logb lrand48 matherr mkdir mktime perror poll random realpath rename res_init rint rmdir select setitimer setpgid setlocale setsid sigblock sighold sigprocmask strcasecmp strerror tzset utimes waitpid)
+AC_HAVE_FUNCS(acosh asinh atanh cbrt closedir dup2 eaccess fmod fpathconf frexp ftime gethostname getpagesize gettimeofday getcwd getwd logb lrand48 matherr mkdir mktime perror poll random realpath rename res_init rint rmdir select setitimer setpgid setlocale setsid sigblock sighold sigprocmask strcasecmp strerror tzset utimes waitpid)
 
 # Check for mmap.
 found_mmap=true