diff configure.ac @ 3309:ad7894a4ab41

[xemacs-hg @ 2006-03-27 21:00:01 by james] Fix ALSA detection by detecting a header file with no dependencies. See xemacs-patches message with ID <m3vetzvc39.fsf@jerrypc.cs.usu.edu>.
author james
date Mon, 27 Mar 2006 21:00:13 +0000
parents 34cfe24248f6
children b145b32294ff
line wrap: on
line diff
--- a/configure.ac	Mon Mar 27 17:40:59 2006 +0000
+++ b/configure.ac	Mon Mar 27 21:00:13 2006 +0000
@@ -5131,7 +5131,7 @@
 
 dnl ALSA sound support
 if test "$enable_sound_alsa" != "no"; then
-  AC_CHECK_HEADER([alsa/pcm.h], [
+  AC_CHECK_HEADER([alsa/input.h], [
     AC_CHECK_LIB(asound, snd_pcm_open, have_alsa_sound=yes)])
   if test "$have_alsa_sound" = "yes"; then
     enable_sound_alsa=yes