diff configure.in @ 197:acd284d43ca1 r20-3b25

Import from CVS: tag r20-3b25
author cvs
date Mon, 13 Aug 2007 10:00:02 +0200
parents f53b5ca2e663
children eb5470882647
line wrap: on
line diff
--- a/configure.in	Mon Aug 13 09:59:07 2007 +0200
+++ b/configure.in	Mon Aug 13 10:00:02 2007 +0200
@@ -449,7 +449,7 @@
 			Get it from the XEmacs FTP site.
 --with-png (*)		Compile with support for PNG image conversion.
 			Requires libpng.  Get it from the XEmacs FTP site.
---with-tiff		Compile with support for TIFF image conversion
+--with-tiff (*)		Compile with support for TIFF image conversion
 			(not yet implemented).
 
 
@@ -2440,13 +2440,15 @@
 AC_SUBST(libs_xauth)
 
 dnl Autodetect OffiX
+OFFIX_O=""
 test -z "$with_offix" && { AC_CHECK_HEADER(OffiX/DragAndDrop.h, , with_offix=no) }
 test -z "$with_offix" && { AC_CHECK_LIB(Dnd, DndInitialize, [:] , with_offix=no) }
 test -z "$with_offix" && with_offix=yes
 if test "$with_offix" = "yes"; then
   AC_DEFINE(HAVE_OFFIX_DND)
-  XE_PREPEND(-lDnd, libs_x)
+  OFFIX_O="offix.o"
 fi
+AC_SUBST(OFFIX_O)
 
 dnl Autodetect tooltalk
 test "$with_cde" = "yes" && with_tooltalk=yes # CDE requires tooltalk
@@ -2581,7 +2583,14 @@
     XE_PREPEND($png_libs, libs_x)
   fi
 
-  dnl autodetect TIFF (not yet implemented)
+  dnl autodetect TIFF
+  if test "$with_tiff" != no; then
+    for extra_libs in "" "-lz" "-lgz"; do
+      AC_CHECK_LIB(tiff, TIFFReadScanline, 
+        tiff_libs="-ltiff $extra_libs" with_tiff=yes; break, [:], $extra_libs)
+    done
+  fi
+  test -z "$with_tiff" && with_tiff=no
   if test "$with_tiff" = "yes"; then
     AC_DEFINE(HAVE_TIFF)
     XE_PREPEND(-ltiff, libs_x)