diff configure.ac @ 2790:ac63ab256048

[xemacs-hg @ 2005-05-28 04:51:22 by stephent] enable new allocator for release <871x7sklah.fsf@tleepslib.sk.tsukuba.ac.jp>
author stephent
date Sat, 28 May 2005 04:51:41 +0000
parents d5863780dbef
children ff857b8541b7
line wrap: on
line diff
--- a/configure.ac	Fri May 27 21:51:24 2005 +0000
+++ b/configure.ac	Sat May 28 04:51:41 2005 +0000
@@ -1993,6 +1993,10 @@
   lib_gcc=
 fi
 
+dnl Enable KKCC and MC-ALLOC by default
+test -z "$enable_kkcc" && enable_kkcc=yes
+test -z "$enable_mc_alloc" && enable_mc_alloc=yes
+
 dnl Dump into executable
 if test -z "$enable_dump_in_exec"; then
   if test "$enable_pdump" = "yes"; then
@@ -5741,8 +5745,22 @@
   echo "  WARNING: More recent versions may be safer, or not."
   echo "  WARNING: ---------------------------------------------------------"
 fi
-test "$enable_kkcc" = yes && echo "  Using the new GC algorithms."
-test "$enable_mc_alloc" = yes && echo "  Using the new allocator."
+if test "$enable_kkcc" = yes ; then
+  echo "  Using the new GC algorithms."
+  echo "  WARNING: ---------------------------------------------------------"
+  echo "  WARNING: The new algorithms are experimental. They are enabled by"
+  echo "  WARNING: default for this release. Use \`--disable-kkcc' to"
+  echo "  WARNING: turn it off."
+  echo "  WARNING: ---------------------------------------------------------"
+fi
+if test "$enable_mc_alloc" = yes ; then
+  echo "  Using the new allocator."
+  echo "  WARNING: ---------------------------------------------------------"
+  echo "  WARNING: The new allocator is experimental. It is enabled by"
+  echo "  WARNING: default for this release. Use \`--disable-mc-alloc' to"
+  echo "  WARNING: turn it off."
+  echo "  WARNING: ---------------------------------------------------------"
+fi
 test "$enable_pdump" = yes && echo "  Using the new portable dumper."
 test "$enable_dump_in_exec" = yes && echo "  Dumping into executable."
 test "$enable_debug" = yes && echo "  Compiling in support for extra debugging code."