diff configure.in @ 2:ac2d302a0011 r19-15b2

Import from CVS: tag r19-15b2
author cvs
date Mon, 13 Aug 2007 08:46:35 +0200
parents 376386a54a3c
children 27bc7f280385
line wrap: on
line diff
--- a/configure.in	Mon Aug 13 08:45:53 2007 +0200
+++ b/configure.in	Mon Aug 13 08:46:35 2007 +0200
@@ -115,7 +115,7 @@
 native_sound_lib=''
 # make normal error-checking be the default in alpha and beta versions, so
 # that bugs get noticed.  Change this for released versions.
-error_check_default='no'
+error_check_default='yes'
 error_check_extents=$error_check_default
 error_check_typecheck=$error_check_default
 error_check_bufpos=$error_check_default
@@ -226,6 +226,7 @@
 			 Motif dialog boxes will be used if Motif can be
 			 found.)
 --with-cde (*)		Compile in support for CDE drag and drop.
+--with-offix (*)	Compile in support for OffiX drag and drop.
 --with-xpm (*)		Compile with support for XPM files.
 			It is highly recommended that you obtain XPM
 			(version 3.4g or better) if you don't already
@@ -640,6 +641,22 @@
           eval "${opt}=\"${val}\""
         ;;
 
+        ## Has the user requested OffiX support?
+	"with_offix" )
+	  ## Make sure the value given was either "yes" or "no".
+	  case "${val}" in
+	    y | ye | yes )	val=yes ;;
+	    n | no )		val=no  ;;
+	    * )
+	      (echo "${progname}: the \`--${optname}' option is supposed to have a boolean value.
+Set it to either \`yes' or \`no'."
+	       echo "${short_usage}") >&2
+	      exit 1
+	    ;;
+	  esac
+          eval "${opt}=\"${val}\""
+        ;;
+
         ## Has the user requested XPM support?
 	"with_xpm" )
 	  ## Make sure the value given was either "yes" or "no".
@@ -2140,14 +2157,14 @@
     case "${canonical}" in
       ## The Sun386 didn't get past 4.0.
       i[3-9]86-*-sunos4	   ) opsys=sunos4-0      ;;
-      *-sunos4.0*	   ) opsys=sunos4-0      ;;
-      *-sunos4.1.2*        ) opsys=sunos4-1-2    ;;
-      *-sunos4.1.[3-9]*	   ) opsys=sunos4-1-3    ;;
       *-sunos4shr*	   ) opsys=sunos4-0shr   ;;
       *-sunos4-0shr*	   ) opsys=sunos4-0shr   ;;
       *-sunos4-1shr*	   ) opsys=sunos4-1shr   ;;
       *-sunos4-1-2shr*	   ) opsys=sunos4-1-2shr ;;
       *-sunos4-1-[3-9]shr* ) opsys=sunos4-1-3shr ;;
+      *-sunos4.0*	   ) opsys=sunos4-0      ;;
+      *-sunos4.1.2*        ) opsys=sunos4-1-2    ;;
+      *-sunos4.1.[3-9]*	   ) opsys=sunos4-1-3    ;;
       *-sunos4* | *-sunos  ) opsys=sunos4-1	 ;;
 
       *-solaris2.3*	   ) opsys=sol2-3 	 ;;
@@ -2730,6 +2747,10 @@
     ] AC_WARN(--with-cde ignored:  Not valid without X support) [
     with_menubars='no'
   fi
+  if [ "x${with_offix}" != x ]; then
+    ] AC_WARN(--with-offix ignored:  Not valid without X support) [
+    with_offix='no'
+  fi
   if [ "x${with_menubars}" != x ]; then
     ] AC_WARN(--with-menubars ignored:  Not valid without X support) [
     with_menubars='no'
@@ -2747,6 +2768,7 @@
     with_toolbars='no'
   fi
   with_cde='no'
+  with_offix='no'
   with_menubars='no'
   with_scrollbars='no'
   with_dialogs='no'
@@ -3197,6 +3219,33 @@
 fi
 
 #
+# See if we can find OffiX.
+#
+if test "${window_system}" != "none" ; then
+  if test "${with_offix}" != "no" ; then
+    if test "${with_offix}" != "yes" ; then
+      internal_offix_lib_found='no'
+      AC_HAVE_LIBRARY(-lDnd, internal_offix_lib_found='yes')
+      if test "${internal_offix_lib_found}" = "yes" ; then
+        internal_offix_includes_found='no'
+        for arg in ${DEFS} /usr/include
+          do
+            if test -f `echo "${arg}/OffiX/DragAndDrop.h" | sed 's/^\-I//'` ; then
+  	      internal_offix_includes_found='yes'
+            fi
+          done
+        if test "${internal_offix_includes_found}" = "yes" ; then
+          with_offix='yes'
+        fi
+      fi
+    fi
+  fi
+fi
+if test "${with_offix}" = "yes" ; then
+  AC_DEFINE(HAVE_OFFIX_DND)
+fi
+
+#
 # See if we can find Xlocale.h.
 #
 with_xlocale_h='no'
@@ -4315,6 +4364,9 @@
 if [ "$with_cde" = "yes" ]; then
   echo "  Compiling in support for CDE."
 fi
+if [ "$with_offix" = "yes" ]; then
+  echo "  Compiling in support for OffiX."
+fi
 if [ "$with_mocklisp" = "yes" ]; then
   echo "  Compiling in support for Mocklisp."
 fi