diff configure.in @ 800:a5954632b187

[xemacs-hg @ 2002-03-31 08:27:14 by ben] more fixes, first crack at finishing behavior implementation TODO.ben-mule-21-5: Update. configure.in: Fix for new error-checking types. make-mswin-unicode.pl: Don't be fucked up by CRLF. Output code to force errors when nonintercepted Windows calls issued. behavior.el, dumped-lisp.el, menubar-items.el: Add support for saving using custom. Load into a dumped XEmacs. Correct :title to :short-doc in accordance with behavior-defs.el. Add a submenu under Options for turning on/off behaviors. cl-macs.el: Properly document `loop'. Fix a minor bug in keymap iteration and add support for bit-vector iteration. lisp-mode.el: Rearrange and add items for macro expanding. menubar-items.el: Document connection between these two functions. window.el: Port stuff from GNU 21.1. config.inc.samp, xemacs.mak: Separate out and add new variable for controlling error-checking. s/windowsnt.h: Use new ERROR_CHECK_ALL; not related to DEBUG_XEMACS. alloc.c, backtrace.h, buffer.c, buffer.h, bytecode.c, callproc.c, casetab.c, charset.h, chartab.c, cmdloop.c, config.h.in, console-msw.c, console-stream.c, console-tty.c, console.c, console.h, data.c, device-msw.c, device.c, device.h, dired-msw.c, dired.c, dumper.c, editfns.c, eldap.c, elhash.c, emacs.c, eval.c, event-Xt.c, event-gtk.c, event-msw.c, event-stream.c, events.c, extents.c, faces.c, file-coding.c, file-coding.h, fileio.c, frame-msw.c, frame.c, frame.h, glyphs-gtk.c, glyphs-msw.c, glyphs-shared.c, glyphs-widget.c, glyphs-x.c, glyphs.c, glyphs.h, insdel.c, intl-auto-encap-win32.c, intl-auto-encap-win32.h, intl-encap-win32.c, intl-win32.c, keymap.c, lisp-union.h, lisp.h, lread.c, lrecord.h, lstream.c, lstream.h, macros.c, marker.c, md5.c, menubar-x.c, menubar.c, mule-coding.c, ntproc.c, objects-gtk.c, objects-msw.c, objects-x.c, objects.c, opaque.c, print.c, process-nt.c, process-unix.c, process.c, rangetab.c, redisplay-msw.c, redisplay-output.c, redisplay.c, regex.c, scrollbar-msw.c, select-msw.c, signal.c, specifier.c, specifier.h, symbols.c, sysdep.c, syswindows.h, text.c, text.h, toolbar-msw.c, tooltalk.c, ui-gtk.c, unicode.c, window.c: Redo error-checking macros: ERROR_CHECK_TYPECHECK -> ERROR_CHECK_TYPES, ERROR_CHECK_CHARBPOS -> ERROR_CHECK_TEXT, add ERROR_CHECK_DISPLAY, ERROR_CHECK_STRUCTURES. Document these in config.h.in. Fix code to follow docs. Fix *_checking_assert() in accordance with new names. Attempt to fix periodic redisplay crash freeing display line structures. Add first implementation of sledgehammer redisplay check. Redo print_*() to use write_fmt_string(), write_fmt_string_lisp(). Fix bug in md5 handling. Rename character-to-unicode to char-to-unicode; same for unicode-to-char{acter}. Move chartab documentation to `make-char-table'. Some header cleanup. Clean up remaining places where nonintercepted Windows calls are being used. automated/mule-tests.el: Fix for new Unicode support.
author ben
date Sun, 31 Mar 2002 08:30:17 +0000
parents e65d9cf16707
children 4ead1e0842f0
line wrap: on
line diff
--- a/configure.in	Sat Mar 30 04:46:48 2002 +0000
+++ b/configure.in	Sun Mar 31 08:30:17 2002 +0000
@@ -691,11 +691,11 @@
 	      extents )       error_check_extents=yes ;;
 	      noextents )     error_check_extents=no ;;
 
-	      typecheck )     error_check_typecheck=yes ;;
-	      notypecheck )   error_check_typecheck=no ;;
-
-	      charbpos )	      error_check_charbpos=yes ;;
-	      nocharbpos )      error_check_charbpos=no ;;
+	      types )         error_check_types=yes ;;
+	      notypes )       error_check_types=no ;;
+
+	      text )          error_check_text=yes ;;
+	      notext )        error_check_text=no ;;
 
 	      gc )	      error_check_gc=yes ;;
 	      nogc )          error_check_gc=no ;;
@@ -706,28 +706,36 @@
 	      byte_code )     error_check_byte_code=yes ;;
 	      nobyte_code )   error_check_byte_code=no ;;
 
-	      glyphs )     error_check_glyphs=yes ;;
-	      noglyphs )   error_check_glyphs=no ;;
+	      glyphs )        error_check_glyphs=yes ;;
+	      noglyphs )      error_check_glyphs=no ;;
+
+	      display )       error_check_display=yes ;;
+	      nodisplay )     error_check_display=no ;;
+
+	      structures )    error_check_structures=yes ;;
+	      nostructures )  error_check_structures=no ;;
 
 	      * ) bogus_error_check=yes ;;
 	    esac
 	    if test "$bogus_error_check" -o \
 	         \( -n "$new_default" -a -n "$echeck_notfirst" \) ; then
 		if test "$error_check_default" = yes ; then
-		  types="\`all' (default), \`none', \`noextents', \`notypecheck', \`nocharbpos', \`nogc', \`nomalloc', \`noglyphs' and \`nobyte-code'."
+		  types="\`all' (default), \`none', \`noextents', \`notypes', \`notext', \`nogc', \`nomalloc', \`noglyphs', \`nobyte-code', \`nodisplay', \`nostructures'."
 		else
-		  types="\`all', \`none' (default), \`extents', \`typecheck', \`charbpos', \`gc', \`malloc', \`glyphs' and \`byte-code'."
+		  types="\`all', \`none' (default), \`extents', \`types', \`text', \`gc', \`malloc', \`glyphs', \`byte-code', \`display', \`structures'."
 		fi
 		USAGE_ERROR(["Valid types for the \`--$optname' option are:
   $types."])
 	    elif test -n "$new_default" ; then
 		error_check_extents=$new_default
-		error_check_typecheck=$new_default
-		error_check_charbpos=$new_default
+		error_check_types=$new_default
+		error_check_text=$new_default
 		error_check_gc=$new_default
 		error_check_malloc=$new_default
 		error_check_byte_code=$new_default
 		error_check_glyphs=$new_default
+		error_check_display=$new_default
+		error_check_structures=$new_default
 		new_default=	# reset this
 	    fi
 	    echeck_notfirst=true
@@ -1016,13 +1024,15 @@
 dnl Error checking default to "yes" in beta versions, to "no" in releases.
 dnl Same goes for --debug and --extra-verbosity.
 if test -n "$emacs_is_beta"; then beta=yes; else beta=no; fi
-test "${error_check_extents=$beta}"   = yes && AC_DEFINE(ERROR_CHECK_EXTENTS)
-test "${error_check_typecheck=$beta}" = yes && AC_DEFINE(ERROR_CHECK_TYPECHECK)
-test "${error_check_charbpos=$beta}"    = yes && AC_DEFINE(ERROR_CHECK_CHARBPOS)
-test "${error_check_gc=$beta}"        = yes && AC_DEFINE(ERROR_CHECK_GC)
-test "${error_check_malloc=$beta}"    = yes && AC_DEFINE(ERROR_CHECK_MALLOC)
-test "${error_check_byte_code=$beta}" = yes && AC_DEFINE(ERROR_CHECK_BYTE_CODE)
-test "${error_check_glyphs=$beta}" = yes && AC_DEFINE(ERROR_CHECK_GLYPHS)
+test "${error_check_extents=$beta}"    = yes && AC_DEFINE(ERROR_CHECK_EXTENTS)
+test "${error_check_types=$beta}"      = yes && AC_DEFINE(ERROR_CHECK_TYPES)
+test "${error_check_text=$beta}"       = yes && AC_DEFINE(ERROR_CHECK_TEXT)
+test "${error_check_gc=$beta}"         = yes && AC_DEFINE(ERROR_CHECK_GC)
+test "${error_check_malloc=$beta}"     = yes && AC_DEFINE(ERROR_CHECK_MALLOC)
+test "${error_check_byte_code=$beta}"  = yes && AC_DEFINE(ERROR_CHECK_BYTE_CODE)
+test "${error_check_glyphs=$beta}"     = yes && AC_DEFINE(ERROR_CHECK_GLYPHS)
+test "${error_check_display=$beta}"    = yes && AC_DEFINE(ERROR_CHECK_DISPLAY)
+test "${error_check_structures=$beta}" = yes && AC_DEFINE(ERROR_CHECK_STRUCTURES)
 dnl debug=yes must be set when error checking is present.  This should be
 dnl fixed up.
 dnl debug implies other options
@@ -5008,7 +5018,7 @@
 test "$pdump" = yes && echo "  Using the new portable dumper."
 test "$debug" = yes && echo "  Compiling in support for extra debugging code."
 test "$usage_tracking" = yes && echo "  Compiling in support for active usage tracking (Sun internal)."
-if test "$error_check_extents $error_check_typecheck $error_check_charbpos $error_check_gc $error_check_malloc $error_check_glyphs" \
+if test "$error_check_extents $error_check_types $error_check_text $error_check_gc $error_check_malloc $error_check_glyphs $error_check_byte_code $error_check_display $error_check_structures" \
   != "no no no no no no"; then
   echo "  WARNING: ---------------------------------------------------------"
   echo "  WARNING: Compiling in support for runtime error checking."