diff configure.in @ 375:a300bb07d72d r21-2b3

Import from CVS: tag r21-2b3
author cvs
date Mon, 13 Aug 2007 11:04:51 +0200
parents 6240c7796c7a
children d883f39b8495
line wrap: on
line diff
--- a/configure.in	Mon Aug 13 11:04:07 2007 +0200
+++ b/configure.in	Mon Aug 13 11:04:51 2007 +0200
@@ -2442,6 +2442,7 @@
     AC_DEFINE(HAVE_MS_WINDOWS)
     install_pp="$blddir/lib-src/installexe.sh"
     XE_APPEND(-lshell32 -lgdi32 -luser32 -lcomctl32, libs_system)
+    test "$with_dragndrop" != no && XE_APPEND(msw, dragndrop_proto)
     if test "$window_system" != x11; then
  	window_system=msw
 	test "$with_scrollbars" != "no" && with_scrollbars=msw \
@@ -3557,6 +3558,9 @@
   XE_PREPEND(-Bstatic -lut -Bdynamic, LIBS)
 fi
 
+dnl cygwin can't cope with dlfcn at the moment
+test -z "$with_shlib" && test "$opsys $machine" = "cygwin32 intel386" && with_shlib=no
+
 dnl autodetect dll support
 AC_CHECK_HEADERS(dlfcn.h, have_dlfcn=yes)
 test -z "$with_shlib" && test ! -z "$have_dlfcn" && { AC_CHECK_LIB(dl,  dlopen,   [ AC_DEFINE(HAVE_DLOPEN) DLL_LIB=dl;  with_shlib=yes]) }