diff configure.in @ 179:9ad43877534d r20-3b16

Import from CVS: tag r20-3b16
author cvs
date Mon, 13 Aug 2007 09:52:19 +0200
parents 6075d714658b
children bfd6434d15b3
line wrap: on
line diff
--- a/configure.in	Mon Aug 13 09:51:18 2007 +0200
+++ b/configure.in	Mon Aug 13 09:52:19 2007 +0200
@@ -418,9 +418,9 @@
 --x-includes=DIR 	Search for X header files in DIR.
 --x-libraries=DIR	Search for X libraries in DIR.
 --with-toolbars=no	Don't compile with any toolbar support.
---with-wm		Compile with realized leader window for proper
-			creation of the ApplicationIcon with the
-			WindowMaker windowmanager (SESSION MANAGEMENT).
+--with-session=no	Compile without realized leader window which will
+			keep the WM_COMMAND property. Required for proper
+			session-management. (ON by default for testing)
 --with-menubars=TYPE	Use TYPE menubars (lucid, motif, or no).  The Lucid
 			widgets emulate Motif (mostly) but are faster.
 			*WARNING*  The Motif menubar is currently broken.
@@ -662,7 +662,7 @@
 	with_jpeg	| \
 	with_png	| \
 	with_tiff	| \
-	with_wm		| \
+	with_session	| \
 	with_xmu	| \
 	with_quantify	| \
 	with_toolbars	| \
@@ -2385,9 +2385,9 @@
   if test "$with_tty" = "no" ; then
     AC_MSG_ERROR([No window system support and no TTY support - Unable to proceed.])
   fi
-  for feature in tooltalk cde offix wm \
+  for feature in tooltalk cde offix session \
                  menubars scrollbars toolbars dialogs xim xmu \
-                 tiff png jpeg gif compface xpm
+                 tiff png jpeg gif xface xpm
   do
     if eval "test -n \"\$with_${feature}\" -a \"\$with_${feature}\" != no" ; then
        AC_MSG_WARN([--with-$feature ignored:  Not valid without X support])
@@ -2411,10 +2411,10 @@
   test "$opsys" = "hpux9-shr" && opsysfile="s/hpux9shxr4.h"
 esac
 
-dnl Check for WindowMaker
-AC_CHECKING(for WindowMaker option);
-if test "$with_wm" = "yes"; then
-  AC_DEFINE(HAVE_WINDOWMAKER)
+dnl Enable or disable proper session-management
+AC_CHECKING(for session-management option);
+if test "$with_session" != "no"; then
+  AC_DEFINE(HAVE_SESSION)
 fi
 
 dnl Autodetect Xauth
@@ -3504,7 +3504,7 @@
 test "$with_offix"    = yes && echo "  Compiling in support for OffiX."
 test "$with_workshop" = yes && echo "  Compiling in support for Sun WorkShop."
 test "$with_energize" = yes && echo "  Compiling in support for Lucid Energize (doesn't currently work)."
-test "$with_wm"       = yes && echo "  Compiling in support for WindowMaker."
+test "$with_session"  != no && echo "  Compiling in support for proper session-management."
 case  "$with_menubars" in
   lucid ) echo "  Using Lucid menubars." ;;
   motif ) echo "  Using Motif menubars."