diff configure.ac @ 3959:8fe2dec941b3

[xemacs-hg @ 2007-05-17 15:42:10 by stephent] Fixup error-checking option docstring. <87r6pf8n84.fsf@uwakimon.sk.tsukuba.ac.jp>
author stephent
date Thu, 17 May 2007 15:42:48 +0000
parents cfc59907fb1e
children 51a9ffce4b37
line wrap: on
line diff
--- a/configure.ac	Thu May 17 15:06:04 2007 +0000
+++ b/configure.ac	Thu May 17 15:42:48 2007 +0000
@@ -979,20 +979,21 @@
 XE_MERGED_ARG([debug],
 	AS_HELP_STRING([--enable-debug],[Enable additional debugging information.  No time cost.]),
 	[], [])
+dnl Keep TESTS sorted to help with syncing doc to reality.
 XE_COMPLEX_ARG([error-checking],
 	AS_HELP_STRING([--enable-error-checking=TESTS],[Compile with internal error-checking added.
                         Causes noticeable loss of speed.  Valid TESTS
-                        are `extents', `bufpos', `malloc', `gc', `types', `text', `byte_code', `glyphs', `display', `structures'.]),
+                        are `byte_code', `display', `extents', `gc', `glyphs', `malloc', `structures' `text', `types'.]),
 	[], [],
-[XE_COMPLEX_OPTION([extents],[""]),
- XE_COMPLEX_OPTION([types],[""]),
- XE_COMPLEX_OPTION([text],[""]),
+[XE_COMPLEX_OPTION([byte_code],[""]),
+ XE_COMPLEX_OPTION([display],[""]),
+ XE_COMPLEX_OPTION([extents],[""]),
  XE_COMPLEX_OPTION([gc],[""]),
+ XE_COMPLEX_OPTION([glyphs],[""]),
  XE_COMPLEX_OPTION([malloc],[""]),
- XE_COMPLEX_OPTION([byte_code],[""]),
- XE_COMPLEX_OPTION([glyphs],[""]),
- XE_COMPLEX_OPTION([display],[""]),
- XE_COMPLEX_OPTION([structures],[""])])
+ XE_COMPLEX_OPTION([structures],[""])
+ XE_COMPLEX_OPTION([text],[""]),
+ XE_COMPLEX_OPTION([types],[""]),])
 XE_MERGED_ARG([assertions],
 	AS_HELP_STRING([--enable-assertions],[Compile in runtime assertions.]),
 	[], [])