diff configure.in @ 2491:876c400e58d7

[xemacs-hg @ 2005-01-21 09:30:46 by aidan] NetBSD can use Linux's sound API, but it needs an extra library at link time to do so.
author aidan
date Fri, 21 Jan 2005 09:30:49 +0000
parents 97dd9f867cef
children 38caebdefb55
line wrap: on
line diff
--- a/configure.in	Thu Jan 20 22:51:57 2005 +0000
+++ b/configure.in	Fri Jan 21 09:30:49 2005 +0000
@@ -4697,7 +4697,16 @@
     done
   fi
 
-  test "$sound_found" = "yes" && with_native_sound=yes
+  if test "$sound_found" = "yes"; then
+     with_native_sound=yes
+
+     dnl NetBSD can use Linux's sound API, but it needs an extra library at
+     dnl link time to do so. (OpenBSD apparently needs the same; not written
+     dnl or tested.)
+     if test "$opsys" = "netbsd" ; then 
+         AC_CHECK_LIB(ossaudio, _oss_ioctl, native_sound_lib="-lossaudio")
+     fi
+  fi
 fi
 
 if test "$with_native_sound" = "yes"; then