diff configure.ac @ 5494:861f2601a38b

Sync s/ files with GNU 23.1.92, delete obsolete stuff, simplify other stuff --- ChangeLog 2010-02-20 Ben Wing <ben@xemacs.org> * configure: * configure.ac (XE_EXPAND_VARIABLE): * configure.ac (TAB): irix6-0.h renamed to irix6-5.h; sco7.h deleted. bsd4-3.h renamed to bsd-common.h. Simplify setting machine= for intel386, mips. Put back linux.h. Incorporate some stuff about debug/optimization flags in irix6-5.h into configure.ac. Add a comment about LCC stuff with optimization flags that should be fixed up. --- src/ChangeLog 2010-02-20 Ben Wing <ben@xemacs.org> * sysdep.c: * sysdep.c (qxe_reliable_signal): * sysdep.c (retry_open_1): * sysdep.c (retry_close): * sysdep.c (retry_read_1): * sysdep.c (retry_write_1): * sysdep.c (retry_fopen): * sysdep.c (retry_fclose): * sysdep.c (retry_fread): * sysdep.c (retry_fwrite): Remove conditionalization on INTERRUPTIBLE_IO, INTERRUPTIBLE_OPEN, INTERRUPTIBLE_CLOSE -- always check for EINTR as there's no harm in it. Remove old #if 0'ed out SA_RESTART code. Use manifest constant IRIX6_5 instead of IRIX. * Makefile.in.in: * dired.c: * dired.c (Ffile_attributes): Use manifest constant IRIX6_5 instead of IRIX. Eliminate constant BSD4_2, use BSD4_3 instead. * getloadavg.c: * getloadavg.c (getloadavg): * getloadavg.c (LDAV_PRIVILEGED): * getloadavg.c (LDAV_DONE): Sync with GNU 23.1.92. 2010-02-20 Ben Wing <ben@xemacs.org> * s/README: * s/aix4-2.h: * s/aix4-2.h (MAIL_USE_LOCKF): * s/bsd-common.h: * s/freebsd.h: * s/freebsd.h (Carey): * s/freebsd.h (or): * s/gnu.h: * s/gnu.h (DATA_START): * s/hpux11-shr.h: * s/hpux11.h: * s/hpux11.h (random): * s/irix6-5.h: * s/linux.h: * s/mach-bsd4-3.h: * s/netbsd.h: * s/netbsd.h (or): * s/netbsd.h (A_TEXT_OFFSET): * s/netbsd.h (NO_MATHERR): * s/openbsd.h: * s/sol2.h: * s/usg5-4-2.h: * s/usg5-4.h: * s/usg5-4.h (or): * s/usg5-4.h (ORDINARY_LINK): Sync with GNU 23.1.92. Put back linux.h. Rename: bsd4-3.h -> bsd-common.h; irix6-0.h -> irix6-5.h. Delete: template.h (useless). Delete a whole bunch of obsolete stuff in sol2.h, linux.h, freebsd.h -- assume anything over 10 years old is sufficiently obsolete to be deleted. Remove LIBS_DEBUG, C_DEBUG_SWITCH, C_OPTIMIZE_SWITCH, KERNEL_FILE, LDAV_SYMBOL, most remaining PTY stuff, remaining TERMINFO/TERMCAP stuff. Update README appropriately. Remove stuff in hpux11-shr.h duplicated in hpux11.h. Remove sco7.h, identical with usg5-4-2.h. Remove unused POSIX flag, BROKEN_TIOC*, NO_SIOCTL_H. 2010-02-20 Ben Wing <ben@xemacs.org> * m/arm.h: * m/hp800.h: * m/intel386.h: * m/mips.h: * m/powerpc.h: * m/sparc.h: * m/template.h: Temporarily ifdef out all defines involving load-average stuff -- using define ENABLE_SM_FILE_DECLS_OF_LOADAVG_STUFF, which is not defined. I'm pretty sure getloadavg.c will take care of defining stuff properly on all systems without the need to duplicate the info in m/*. --ben Delete LIBS_TERMCAP; configure auto-handles this. Delete extra stuff in hp800.h. Delete C_DEBUG_SWITCH, C_OPTIMIZE_SWITCH, LDAV_SYMBOL; incorporate some stuff into configure.ac.
author Ben Wing <ben@xemacs.org>
date Sat, 20 Feb 2010 06:03:00 -0600
parents 2ade80e8c640
children 1f0b15040456
line wrap: on
line diff
--- a/configure.ac	Fri Feb 19 22:41:03 2010 -0600
+++ b/configure.ac	Sat Feb 20 06:03:00 2010 -0600
@@ -1320,16 +1320,18 @@
 case "$ac_cv_build" in
   sparc-*-*        ) machine=sparc ;;
   alpha*-*-*       ) machine=alpha ;;
-  mips*-linux      ) machine=mips ;;
+  mips*-*          ) machine=mips ;;
   rs6000-ibm-aix*  ) machine=ibmrs6000 ;;
   powerpc-ibm-aix* ) machine=ibmrs6000 ;;
   powerpc*-*       ) machine=powerpc ;;
   hppa-*-*         ) machine=hp800 ;;
   arm*             ) machine=arm ;;
+  i[[3-9]]86-*-*   ) machine=intel386 ;;
 esac
 
 dnl Straightforward OS determination
 case "$ac_cv_build" in
+  *-*-linux*    ) opsys=linux ;;
   *-*-netbsd*   ) opsys=netbsd ;;
   *-*-openbsd*	) opsys=openbsd ;;
 
@@ -1338,8 +1340,8 @@
 
   dnl Other generic OSes
   *-gnu* )			opsys=gnu    ;;
-  *-*-bsd4.3 )			opsys=bsd4-3 ;;
-  *-*-aos*   )			opsys=bsd4-3 ;;
+  *-*-bsd4.3 )			opsys=bsd-common ;;
+  *-*-aos*   )			opsys=bsd-common ;;
   *-*-sysv4.1* | *-*-sysvr4.1* )opsys=usg5-4 NON_GNU_CPP=/usr/lib/cpp ;;
   *-*-sysv4.[[2-9]]* | *-sysvr4.[[2-9]]* )
 	if test -z "$NON_GNU_CPP" ; then
@@ -1354,20 +1356,6 @@
 
 case "$ac_cv_build" in
 
-  dnl NetBSD ports
-  *-*-netbsd* )
-    case "${ac_cv_build}" in
-      i[[3-9]]86-*-netbsd*) machine=intel386 ;;
-    esac
-  ;;
-
-  dnl OpenBSD ports
-  *-*-openbsd* )
-    case "${ac_cv_build}" in
-      i386-*-openbsd*)		machine=intel386 ;;
-     esac
-   ;;
-
   dnl Darwin, a.k.a. MacOS X (based on Mach and Freebsd)
   *-*-darwin*)
     opsys=darwin
@@ -1385,20 +1373,15 @@
   dnl Workstations sold by MIPS
   dnl This is not necessarily all workstations using the MIPS processor -
   dnl Irises are produced by SGI, and DECstations by DEC.
-  mips-mips-bsd* ) machine=mips opsys=bsd4-3 ;;
-  mips-mips-*    ) machine=mips opsys=usg5-4-2 ;;
+  mips-mips-bsd* ) opsys=bsd-common ;;
+  mips-mips-*    ) opsys=usg5-4-2 ;;
 
   dnl Silicon Graphics machines
   dnl Iris 4D
-  mips-sgi-irix6*     ) opsys=irix6-0 ;;
+  mips-sgi-irix6*     ) opsys=irix6-5 ;;
 
   dnl Suns
   *-*-solaris* | *-sun-mach* | *-sun-bsd* )
-    dnl Hardware type
-    case "$ac_cv_build" in
-      i*86-*-* )	         machine=intel386 ;;
-    esac
-
     dnl Make $canonical even more so.
     case "$ac_cv_build" in *-sunos5*)
       ac_cv_build=`echo $ac_cv_build | sed -e s/sunos5/solaris2/`;;
@@ -1422,7 +1405,7 @@
 	AC_DEFINE_UNQUOTED(OS_RELEASE, $os_release) ;;
 
       *-mach*		  ) opsys=mach-bsd4-3	;;
-      *			  ) opsys=bsd4-3	;;
+      *			  ) opsys=bsd-common	;;
     esac
 
     dnl Watch out for a compiler guaranteed not to work.
@@ -1431,10 +1414,9 @@
 
   dnl Intel 386 machines where we do not care about the manufacturer
   i[[3-9]]86-*-* )
-    machine=intel386
     case "$ac_cv_build" in
       *-mach* )			opsys=mach-bsd4-3 ;;
-      *-sysv5* )		opsys=sco7 ;;
+      *-sysv5* )		opsys=usg5-4-2 ;;
       *-freebsd* )		opsys=freebsd ;;
       *-pc-cygwin* )		opsys=cygwin32 ;;
       *-pc-mingw* )		opsys=mingw32 ;
@@ -1990,6 +1972,16 @@
       with_cflags_optimization="-O3 -qstrict -qnoansialias -qlibansi -qmaxmem=20000"
     elif test "$__ICC" = "yes"; then
       with_cflags_optimization="-O3 -Ob2"
+    elif test "$opsys" = "irix6-5"; then
+      dnl Optimize, inaccurate debugging, increase limit on size of what's
+      dnl optimized.
+      dnl
+      dnl This should also be applicable other than on Irix 6.5, but I don't
+      dnl know for which compiler versions.  -- fx
+      with_cflags_optimization="-O -OPT:Olimit=3500"
+    dnl #### FIXME FOR LCC:
+    dnl elif test "USE_LCC" = "yes"; then
+    dnl   with_cflags_optimization="-O4 -Oi"
     dnl ### Add optimal cflags_optimization support for other compilers HERE!
     else
       with_cflags_optimization="-O" ;dnl The only POSIX-approved flag
@@ -2006,11 +1998,16 @@
 
 AC_MSG_CHECKING([for preferred debugging flags])
 if test "$cflags_debugging_specified" = "no"; then
+  if test "$GCC" = "no" -a "$opsys" = "irix6-5" -a "$with_optimization" = "yes" ; then
+    dnl MIPSpro C special debugging stuff for use with optimization
+    with_cflags_debugging="-g3"
   dnl ### Add optimal debugging support for other compilers HERE!
-  with_cflags_debugging="-g"
+  else
+    with_cflags_debugging="-g"
+  fi
   
   debugging_ok_with_optimization=no
-  if test "$GCC" = "yes" -o "$CC" = "xlc" -o "$__ICC" = "yes"; then
+  if test "$GCC" = "yes" -o "$CC" = "xlc" -o "$__ICC" = "yes" -o "$opsys" = "irix6-5"; then
     debugging_ok_with_optimization=yes
   fi
   
@@ -4479,6 +4476,7 @@
   AC_CHECK_HEADERS(strtio.h) dnl TIOCSIGNAL
 fi
 
+dnl There is also AC_FUNC_GETLOADAVG; why don't we use it?
 dnl Check whether the system provides getloadavg().
 AC_CHECK_FUNCS(getloadavg)