diff configure.ac @ 4537:7ca6d57ce12d

Clarify syntax in configure.ac following Vladimir Ivanovic's change. 2008-12-27 Aidan Kehoe <kehoea@parhasard.net> * configure.ac: Vladimir Ivanovic's change of 2008-09-17 was effective, but not correct. The original issue was that m4 stripped [], so "char *v[]" in configure.ac became "char *v" in configure. His change to configure.ac rendered the declaration "char **v[]", which is effective but confusing; this change renders it "char **v". * configure: Regenerate.
author Aidan Kehoe <kehoea@parhasard.net>
date Sat, 27 Dec 2008 15:30:50 +0000
parents 0ed907d0f1e9
children fe64f1351cbd
line wrap: on
line diff
--- a/configure.ac	Sat Dec 27 15:28:43 2008 +0000
+++ b/configure.ac	Sat Dec 27 15:30:50 2008 +0000
@@ -3434,7 +3434,7 @@
 
   AC_MSG_CHECKING(the version of X11 being used)
   AC_RUN_IFELSE([AC_LANG_SOURCE([#include <X11/Intrinsic.h>
-    int main(int c, char **v[]) { return c>1 ? XlibSpecificationRelease : 0; }])],
+    int main(int c, char **v) { return c>1 ? XlibSpecificationRelease : 0; }])],
     [./conftest foobar; x11_release=$?],[x11_release=4],[x11_release=4])
   AC_MSG_RESULT(R${x11_release})
   AC_DEFINE_UNQUOTED(THIS_IS_X11R${x11_release})
@@ -5582,7 +5582,7 @@
 dnl One of the above link tests may have succeeded but caused resulting
 dnl executables to fail to run.  Also any tests using AC_RUN_IFELSE will
 dnl have reported incorrect results.
-AC_RUN_IFELSE([AC_LANG_SOURCE([int main(int c,char **v[]){return 0;}])],[:],[
+AC_RUN_IFELSE([AC_LANG_SOURCE([int main(int c,char **v){return 0;}])],[:],[
   echo ""
   echo "*** PANIC *** The C compiler can no longer build working executables."
   echo "*** PANIC *** Please examine the tail of config.log for runtime errors."