diff configure.in @ 527:7b35ad872326

[xemacs-hg @ 2001-05-10 08:09:13 by yoshiki] Malcolm Purvis's patch "[PATCH] Ximian an unsupported version of GTK?", <m166frq0wn.fsf@co3018576-a.rivrw1.nsw.optushome.com.au> * configure.in: Check gtk version validity only when gtk-config exists.
author yoshiki
date Thu, 10 May 2001 08:09:23 +0000
parents 6495d35ba9df
children c69610198c35
line wrap: on
line diff
--- a/configure.in	Wed May 09 17:18:32 2001 +0000
+++ b/configure.in	Thu May 10 08:09:23 2001 +0000
@@ -2548,16 +2548,16 @@
       possible_version=`${possible} --version 2> /dev/null`
       if test "x${possible_version}" != "x"; then
               GTK_CONFIG="${possible}"
+	      case "${possible_version}" in
+        	1.0.*) AC_MSG_WARN([GTK 1.2 is required, please upgrade your version of GTK.]); with_gtk=no;;
+	        1.3.*) AC_MSG_WARN([GTK 1.3 is not supported right now]); with_gtk=no;;
+		1.2.*)
+			with_gtk=yes
+			break
+			;;
+	        *)     AC_MSG_WARN([Found unsupported version of GTK: $possible_version]);;
+	      esac
       fi
-      case "${possible_version}" in
-        1.0.*) AC_MSG_WARN([GTK 1.2 is required, please upgrade your version of GTK.]); with_gtk=no;;
-        1.3.*) AC_MSG_WARN([GTK 1.3 is not supported right now]); with_gtk=no;;
-	1.2.*)
-		with_gtk=yes
-		break
-		;;
-        *)     AC_MSG_WARN([Found unsupported version of GTK: $possible_version]);;
-      esac
    done
    AC_MSG_RESULT([${GTK_CONFIG}])
 fi