diff configure.ac @ 3481:71532ccbd8e3

[xemacs-hg @ 2006-06-29 14:51:59 by stephent] Maybe create $srcdir/src/depend.
author stephent
date Thu, 29 Jun 2006 14:52:00 +0000
parents bf3ba03cef15
children f5e111f9411d
line wrap: on
line diff
--- a/configure.ac	Wed Jun 28 21:51:22 2006 +0000
+++ b/configure.ac	Thu Jun 29 14:52:00 2006 +0000
@@ -6218,6 +6218,14 @@
 dnl module Makefiles will have the common text in
 dnl modules/common/Makefile.common appended.
 
+dnl this actually should be conditional on having perl (ie, effectively
+dnl unconditional on sane systems)
+if test -r $srcdir/src/depend; then :;
+else
+  echo "creating $srcdir/src/depend"
+  perl $srcdir/src/make-src-depend > $srcdir/src/depend
+fi
+
 for file in $internal_makefile_list; do
   case $file in
     src/Makefile.in ) file="src/Makefile.in:src/Makefile.in.in:src/depend" ;;