diff configure.ac @ 3739:6d4dc9ec7240

[xemacs-hg @ 2006-12-11 19:43:57 by aidan] Check for the various u*_t types in configure, use those definitions in C.
author aidan
date Mon, 11 Dec 2006 19:44:56 +0000
parents 23dd32cedb6a
children 995ea1223b4d
line wrap: on
line diff
--- a/configure.ac	Mon Dec 11 13:32:41 2006 +0000
+++ b/configure.ac	Mon Dec 11 19:44:56 2006 +0000
@@ -5376,6 +5376,9 @@
      "$enable_database_dbm"  = "yes" && \
   AC_DEFINE(HAVE_DBM)
 
+dnl Check for u_int*_t typedefs.
+AC_CHECK_TYPES([u_int8_t, u_int16_t, u_int32_t])
+
 dnl Check for Berkeley DB.
 if test "$enable_database_berkdb" != "no"; then
   AC_MSG_CHECKING(for Berkeley db.h)
@@ -5386,14 +5389,22 @@
 #ifdef HAVE_INTTYPES_H
 #define __BIT_TYPES_DEFINED__
 #include <inttypes.h>
+#if !HAVE_U_INT8_T
 typedef uint8_t  u_int8_t;
+#endif
+#if !HAVE_U_INT16_T
 typedef uint16_t u_int16_t;
+#endif
+#if !HAVE_U_INT32_T
 typedef uint32_t u_int32_t;
+#endif
 #ifdef WE_DONT_NEED_QUADS
+#if !HAVE_U_INT64_T
 typedef uint64_t u_int64_t;
 #endif
 #endif
 #endif
+#endif
 #include <$header>
 ])], db_h_file="$header"; break)
   done