diff configure.in @ 1800:6c853dd06f0d

[xemacs-hg @ 2003-11-20 16:06:00 by james] And one more commit because our broken archive won't take toplevel stuff the first time.
author james
date Thu, 20 Nov 2003 16:06:05 +0000
parents b5db5c9230b1
children b37a2b08a901
line wrap: on
line diff
--- a/configure.in	Thu Nov 20 16:04:47 2003 +0000
+++ b/configure.in	Thu Nov 20 16:06:05 2003 +0000
@@ -4196,6 +4196,16 @@
 AC_C_INLINE
 test "$ac_cv_c_inline" != "no" -a "$GCC" = "yes" && XE_ADD_OBJS(inline.o)
 
+dnl check for the typeof extension
+AC_MSG_CHECKING(for typeof)
+AC_TRY_COMPILE(, [int i; __typeof__(i) j;], typeofname="__typeof__",
+  [AC_TRY_COMPILE(, [int i; typeof(i) j;], typeofname="typeof",
+   typeofname=no)])
+AC_MSG_RESULT($typeofname)
+if test "$typeofname" != "no"; then
+  AC_DEFINE_UNQUOTED(TYPEOF, $typeofname)
+fi
+
 dnl HP-UX has a working alloca in libPW.
 dnl case "${GCC}${opsys}" in hpux* )
 dnl  AC_CHECK_FUNC(alloca, [:], [AC_CHECK_LIB(PW, alloca)])