diff configure.in @ 257:65c19d2020f7 r20-5b27

Import from CVS: tag r20-5b27
author cvs
date Mon, 13 Aug 2007 10:22:03 +0200
parents 084402c475ba
children 11cf20601dec
line wrap: on
line diff
--- a/configure.in	Mon Aug 13 10:21:19 2007 +0200
+++ b/configure.in	Mon Aug 13 10:22:03 2007 +0200
@@ -350,6 +350,8 @@
 cflags='UNSPECIFIED'
 dynamic=''
 with_x11=''
+with_gung='no'
+with_minimal_tagbits='no'
 rel_alloc='default'
 with_system_malloc='default'
 native_sound_lib=''
@@ -449,9 +451,9 @@
 	with_gcc	| \
 	with_gnu_make	| \
 	dynamic		| \
+	with_gung	| \
 	with_ncurses	| \
 	with_dnet	| \
-	with_term	| \
 	with_socks	| \
 	with_cde	| \
 	with_offix	| \
@@ -1947,6 +1949,8 @@
       (Using Doug Lea's new malloc from the GNU C Library.)"
   fi
   AC_DEFINE(DOUG_LEA_MALLOC)
+  AC_DEFINE(USE_MINIMAL_TAGBITS)
+  with_minimal_tagbits=yes
 fi
 
 dnl Some other nice autoconf tests.  If you add a test here which
@@ -2578,6 +2582,11 @@
   fi
 fi
 
+if test "$with_gung" != "no"; then
+	test "$with_minimal_tagbits" = "no" && AC_DEFINE(USE_MINIMAL_TAGBITS)
+	AC_DEFINE(USE_INDEXED_LRECORD_IMPLEMENTATION)
+fi
+
 dnl ----------------------
 dnl Mule-dependent options
 dnl ----------------------
@@ -3343,7 +3352,6 @@
 fi
 test "$with_i18n3"         = "yes" && AC_DEFINE(I18N3)
 test "$GCC"                = "yes" && AC_DEFINE(USE_GCC)
-test "$with_term"          = "yes" && AC_DEFINE(HAVE_TERM)
 test "$external_widget"    = "yes" && AC_DEFINE(EXTERNAL_WIDGET)
 test "$with_gnu_make"      = "yes" && AC_DEFINE(USE_GNU_MAKE)
 test "$no_doc_file"        = "yes" && AC_DEFINE(NO_DOC_FILE)
@@ -3402,7 +3410,6 @@
 fi
 test "$with_dnet"  = yes && echo "  Compiling in support for DNET."
 test "$with_socks" = yes && echo "  Compiling in support for SOCKS."
-test "$with_term"  = yes && echo "  Compiling in support for TERM."
 test "$with_xauth" = yes && echo "  Compiling in support for XAUTH."
 if test "$with_xmu" != yes -a "$with_x11" = yes; then
   echo "  No Xmu; substituting equivalent routines."
@@ -3481,6 +3488,9 @@
 echo "  The \`Info-default-directory-list' will be initialized from:"
 echo "  INFOPATH=\"$infopath\""
 test "$use_union_type"     = yes && echo "  Using the union type for Lisp_Objects."
+test "$with_minimal_tagbits" != "no" -o "$with_gung" != "no" && \
+		echo "Using Lisp_Objects with minimal tagbits."
+test "$with_gung" != "no" && echo "Using indexed lrecord implementation."
 test "$debug"              = yes && echo "  Compiling in extra code for debugging."
 test "$memory_usage_stats" = yes && echo "  Compiling in code for checking XEmacs memory usage."
 test "$usage_tracking"     = yes && echo "  Compiling with usage tracking active (Sun internal)."