diff configure.in @ 505:6495d35ba9df

[xemacs-hg @ 2001-05-05 08:26:03 by martinb] Fix default value for opsys
author martinb
date Sat, 05 May 2001 08:26:04 +0000
parents 5aa1854ad537
children 7b35ad872326
line wrap: on
line diff
--- a/configure.in	Sat May 05 08:19:18 2001 +0000
+++ b/configure.in	Sat May 05 08:26:04 2001 +0000
@@ -1534,9 +1534,11 @@
 
 esac
 
-dnl Initialize machine and opsys from $canonical if not in our database above.
+dnl Initialize machine from $canonical if not in our database above.
 test -z "$machine" && machine=`echo $canonical | sed 's/-.*$//'`
-test -z "$opsys"   && opsys=`echo $canonical | sed 's/^[^-]*-[^-]*-//'`
+
+dnl Initialize opsys from `uname -s` if not in our database above.
+test -z "$opsys"   && opsys=`uname -s | tr ABCDEFGHIJKLMNOPQRSTUVWXYZ abcdefghijklmnopqrstuvwxyz`
 
 dnl Use configure-time autodetection if s&m not available
 if test -r "${srcdir}/src/m/${machine}.h"; then