diff configure.in @ 2131:646a9dd3e204

[xemacs-hg @ 2004-06-16 10:32:57 by stephent] autoconf hates me <87llinsv64.fsf@tleepslib.sk.tsukuba.ac.jp>
author stephent
date Wed, 16 Jun 2004 10:32:59 +0000
parents 3c2d928e17ad
children 702b5727498a
line wrap: on
line diff
--- a/configure.in	Tue Jun 15 21:50:35 2004 +0000
+++ b/configure.in	Wed Jun 16 10:32:59 2004 +0000
@@ -1763,7 +1763,7 @@
     AC_DEFINE(_XOPEN_SOURCE,500)
     AC_DEFINE(_XOPEN_SOURCE_EXTENDED)
     ;;
-  freebsd4.[5-9])
+  freebsd4*)
     AC_DEFINE(_POSIX_C_SOURCE,199506L)
     dnl #### Do we want these too?  Apparently yes for _XOPEN_SOURCE=500.
     AC_DEFINE(_XOPEN_SOURCE,500)
@@ -2935,9 +2935,13 @@
 	yes|no|gtk|"" )
 	    ;;
 	* )
-	  AC_MSG_WARN([${feature_value} requested for ${feature}, forcing to gtk]) ;;
+	  feature_conflict_with_gtk=yes
+	  AC_MSG_WARN([--with-${feature}=${feature_value} is incompatible with --with-gtk]) ;;
 	esac
       done
+      if test "${feature_conflict_with_gtk}" = "yes"; then
+	XE_DIE(["One or more GUI toolkit features conflict with GTK"])
+      fi
 
       test "${with_scrollbars}" != "no" && with_scrollbars=gtk
       test "${with_toolbars}" != "no" && with_toolbars=gtk
@@ -4778,9 +4782,9 @@
       with_gpm=yes
       AC_DEFINE(HAVE_GPM)
       XE_PREPEND(-lgpm, LIBS)
+    elif test "$with_gpm" = "yes"; then
+      XE_DIE(["GPM requested, but gpm.h or libgpm seems to be missing."])
     else
-      test "$with_gpm" = "yes" && \
-        XE_DIE("GPM requested, but gpm.h or libgpm seems to be missing.")
       with_gpm=no
     fi
   fi