diff configure.in @ 286:57709be46d1b r21-0b41

Import from CVS: tag r21-0b41
author cvs
date Mon, 13 Aug 2007 10:35:03 +0200
parents 558f606b08ae
children e11d67e05968
line wrap: on
line diff
--- a/configure.in	Mon Aug 13 10:34:15 2007 +0200
+++ b/configure.in	Mon Aug 13 10:35:03 2007 +0200
@@ -1038,6 +1038,7 @@
 case "$canonical" in
   *-*-linux*    ) opsys=linux ;;
   *-*-netbsd*   ) opsys=netbsd ;;
+  *-*-openbsd*	) opsys=openbsd ;;
   *-*-nextstep* ) opsys=nextstep ;;
   *-*-vms       ) opsys=vms ;;
 
@@ -1098,6 +1099,19 @@
     esac
   ;;
 
+  dnl OpenBSD ports
+  *-*-openbsd* )
+    case "${canonical}" in
+      alpha*-*-openbsd*)	machine=alpha ;;
+      i386-*-openbsd*)		machine=intel386 ;;
+      m68k-*-openbsd*)		machine=hp9000s300 ;;
+      mipsel-*-openbsd*)	machine=pmax ;;
+      ns32k-*-openbsd*)		machine=ns32000 ;;
+      sparc-*-openbsd*)		machine=sparc ;;
+      vax-*-openbsd*)		machine=vax ;;
+     esac
+   ;;
+
   dnl Acorn RISCiX:
   arm-acorn-riscix1.1* ) machine=acorn opsys=riscix1-1 ;;
   arm-acorn-riscix1.2* | arm-acorn-riscix ) machine=acorn opsys=riscix1-2 ;;
@@ -1718,7 +1732,7 @@
   dnl Following values of CFLAGS are known to work well.
   dnl Should we take debugging options into consideration?
   if   test "$GCC" = "yes"; then
-    CFLAGS="-g -O2 -Wall -Wno-switch"
+    CFLAGS="-g -O3 -Wall -Wno-switch"
     dnl I'm not convinced this is a good idea any more. -sb
     dnl test "$opsys $machine" = "linux intel386" && \
       dnl CFLAGS="$CFLAGS -fno-strength-reduce -malign-loops=2 -malign-jumps=2 -malign-functions=2"
@@ -2716,8 +2730,8 @@
   fi
 
   dnl autodetect TIFF
-  test -z "$with_tiff" && { AC_CHECK_HEADER(tiffio.h,              ,with_tiff=no) }
-  test -z "$with_tiff" && { AC_CHECK_LIB(tiff, TIFFReadScanline,[:],with_tiff=no) }
+  test -z "$with_tiff" && { AC_CHECK_HEADER(tiffio.h,            ,with_tiff=no) }
+  test -z "$with_tiff" && { AC_CHECK_LIB(tiff, TIFFClientOpen,[:],with_tiff=no) }
   test -z "$with_tiff" && with_tiff=yes
   if test "$with_tiff" = "yes"; then
     AC_DEFINE(HAVE_TIFF)