diff configure.in @ 231:557eaa0339bf r20-5b14

Import from CVS: tag r20-5b14
author cvs
date Mon, 13 Aug 2007 10:13:48 +0200
parents 0e522484dd2a
children 41f2f0e326e9
line wrap: on
line diff
--- a/configure.in	Mon Aug 13 10:13:03 2007 +0200
+++ b/configure.in	Mon Aug 13 10:13:48 2007 +0200
@@ -1371,6 +1371,7 @@
       *-386bsd* )	        opsys=386bsd ;;
       *-freebsd* )		opsys=freebsd ;;
       *-nextstep* )		opsys=nextstep ;;
+      *-pc-cygwin32 )		opsys=cygwin32 ;;
       dnl Otherwise, we fall through to the generic opsys code at the bottom.
     esac
   ;;
@@ -2085,6 +2086,21 @@
   no  ) window_system=none HAVE_X_WINDOWS=no  ;;
 esac
 
+if test "$window_system" = "none"; then
+  AC_CHECKING(for MS-Windows)
+  AC_CHECK_LIB(gdi32,main,have_msw=yes)
+  if test "$have_msw" = "yes"; then
+    AC_DEFINE(HAVE_MS_WINDOWS)
+    window_system=msw
+    with_scrollbars=msw
+    with_dialogs=msw
+    with_menubars=no
+    with_toolbars=no
+    with_tty=no
+    XE_ADD_OBJS(console-msw.o device-msw.o event-msw.o frame-msw.o objects-msw.o select-msw.o redisplay-msw.o msw-proc.o scrollbar-msw.o)
+  fi
+fi
+
 if test "$with_x11" = "yes"; then
   AC_DEFINE(HAVE_X_WINDOWS)
   XE_APPEND(lwlib, MAKE_SUBDIR)
@@ -2241,6 +2257,7 @@
 
 case "$window_system" in
   x11  ) HAVE_X_WINDOWS=yes; echo "  Using X11." ;;
+  msw  ) HAVE_X_WINDOWS=no; echo "  Using MS-Windows." ;;
   none ) HAVE_X_WINDOWS=no ; echo "  Using no window system." ;;
 esac