diff configure.ac @ 4833:4dd2389173fc

merge
author Ben Wing <ben@xemacs.org>
date Sun, 10 Jan 2010 01:06:15 -0600
parents 9987da5935bd 5d120deb60ca
children b3ea9c582280
line wrap: on
line diff
--- a/configure.ac	Sun Jan 10 00:49:30 2010 -0600
+++ b/configure.ac	Sun Jan 10 01:06:15 2010 -0600
@@ -1014,6 +1014,9 @@
 XE_MERGED_ARG([purify],
 	AS_HELP_STRING([--with-purify],[Support memory debugging using Purify.]),
 	[], [])
+XE_MERGED_ARG([valgrind],
+	AS_HELP_STRING([--with-valgrind],[Support memory debugging using Valgrind.]),
+	[], [])
 dnl -------------------------------------------------------------------------
 dnl Final command line argument checks.
 
@@ -5491,6 +5494,7 @@
 test "$enable_quick_build" = "yes" && AC_DEFINE(QUICK_BUILD)
 test "$with_purify"        = "yes" && AC_DEFINE(PURIFY)
 test "$with_quantify"      = "yes" && AC_DEFINE(QUANTIFY)
+test "$with_valgrind"      = "yes" && AC_DEFINE(USE_VALGRIND)
 test "$with_pop"           = "yes" && AC_DEFINE(MAIL_USE_POP)
 test "$with_kerberos"      = "yes" && AC_DEFINE(KERBEROS)
 test "$with_hesiod"        = "yes" && AC_DEFINE(HESIOD)
@@ -5806,6 +5810,7 @@
   echo "  WARNING: Error checking is on by default for XEmacs beta releases."
   echo "  WARNING: ---------------------------------------------------------"
 fi
+test "$with_valgrind" = yes && echo "  Compiling in support for memory debugging with Valgrind."
 echo ""
 ) | tee -a Installation
 dnl echo "The above configure report is appended to \"Installation\" file."