diff configure.in @ 357:4711e16a8e49 r21-1-8

Import from CVS: tag r21-1-8
author cvs
date Mon, 13 Aug 2007 10:57:04 +0200
parents 182f72e8cd0d
children 8e84bee8ddd0
line wrap: on
line diff
--- a/configure.in	Mon Aug 13 10:56:23 2007 +0200
+++ b/configure.in	Mon Aug 13 10:57:04 2007 +0200
@@ -2702,6 +2702,9 @@
 if test "$window_system" != "none"; then
   AC_CHECKING(for graphics libraries)
 
+  dnl On IRIX 6, most graphics libraries depend on libCsup
+  AC_CHECK_LIB(Csup,__T_9__nothrow,[LIBS="-lCsup $LIBS"])
+
   dnl Autodetect Xpm
   xpm_problem=""
   if test -z "$with_xpm"; then
@@ -3354,7 +3357,9 @@
     case "$canonical" in
     *-sgi-* )
       if test -z "$native_sound_lib"; then
+       AC_CHECK_HEADER(audio.h, [
         AC_CHECK_LIB(audio, ALopenport, native_sound_lib="-laudio")
+       ])
       fi
       if test -n "$native_sound_lib"; then
         sound_found=yes sound_cflags=""