diff configure.in @ 26:441bb1e64a06 r19-15b96

Import from CVS: tag r19-15b96
author cvs
date Mon, 13 Aug 2007 08:51:32 +0200
parents 4103f0995bd7
children 1917ad0d78d7
line wrap: on
line diff
--- a/configure.in	Mon Aug 13 08:51:05 2007 +0200
+++ b/configure.in	Mon Aug 13 08:51:32 2007 +0200
@@ -1,3 +1,4 @@
+dnl -*- mode: m4; m4-mode-hook : (lambda () (modify-syntax-entry ?\" "\"\"")) ;  -*-
 dnl Synched up with: FSF 19.31.
 dnl (19.29 -- 19.31 use Autoconf 2.x instead of Autoconf 1.x.
 dnl  Some stuff related to this change has not been synched because
@@ -1443,7 +1444,7 @@
 #### have stuck the source on a read-only partition.  Instead we'll
 #### create it as an actual directory later on if it doesn't already
 #### exist.
-for dir in etc lisp info
+for dir in etc man info site-lisp
 do
   if [ ! -d $dir ]; then
     echo Making symbolic link to ${srcdir}/$dir
@@ -1451,6 +1452,20 @@
   fi
 done
 
+# lisp/ is special
+if [ ! -d lisp ]; then
+	mkdir lisp
+	echo Making symbolic links to lisp libraries
+	${LN_S} ${srcdir}/lisp/* ./lisp
+	rm -f ./lisp/*.el ./lisp/site-packages
+	cp ${srcdir}/lisp/*.el lisp
+	if [ -f ${srcdir}/lisp/site-packages ]; then
+		cp ${srcdir}/lisp/site-packages lisp
+	fi
+fi
+
+cp ${srcdir}/lisp/version.el lisp
+
 #### Make srcdir absolute, if it isn't already.  It's important to
 #### avoid running the path through pwd unnecessary, since pwd can
 #### give you automounter prefixes, which can go away.