diff configure.ac @ 2940:3ee1c468b215

[xemacs-hg @ 2005-09-19 00:36:01 by mta] * configure.ac: Fix the cygwin, non-X build by adding XPM header and library files to XE_CFLAGS. Patch from Rick Rankin. * lib-src/installexe.sh: Don't add an exe extention to a file that already has one. Patch from Rick Rankin.
author mta
date Mon, 19 Sep 2005 00:36:05 +0000
parents ff857b8541b7
children 414a64af46c9
line wrap: on
line diff
--- a/configure.ac	Sun Sep 18 21:51:11 2005 +0000
+++ b/configure.ac	Mon Sep 19 00:36:05 2005 +0000
@@ -3755,6 +3755,7 @@
   xpm_problem=""
   if test -z "$with_xpm"; then
     XE_PREPEND("$incpath_xpm", CFLAGS)
+    XE_PREPEND("$incpath_xpm", XE_CFLAGS)
     XE_PREPEND("$libpath_xpm", LDFLAGS)
     AC_MSG_CHECKING(for Xpm - no older than 3.4f)
     xe_check_libs=-lXpm
@@ -3794,6 +3795,7 @@
     XE_PREPEND("$libpath_xpm", LDFLAGS)
     XE_PREPEND(-lXpm, libs_x)
     XE_PREPEND("$incpath_xpm", CFLAGS)
+    XE_PREPEND("$incpath_xpm", XE_CFLAGS)
     AC_MSG_CHECKING(for \"FOR_MSW\" xpm)
     xe_check_libs=-lXpm
     AC_TRY_LINK(, [XpmCreatePixmapFromData()],