diff configure.ac @ 5601:3e5d5e8e4bb7

Move etc/dbxrc.in to src/.dbxrc.in. 2011-11-21 Marcus Crestani <crestani@informatik.uni-tuebingen.de> * .hgignore: * configure.ac: Reflect move of etc/dbxrc.in to src/.dbxrc.in. * configure: Regenerate. 2011-11-21 Marcus Crestani <crestani@informatik.uni-tuebingen.de> * dbxrc.in: Move to src/.dbxrc.in. 2011-11-21 Marcus Crestani <crestani@informatik.uni-tuebingen.de> * .dbxrc.in: Move from etc/.dbxrc.in.
author Marcus Crestani <crestani@informatik.uni-tuebingen.de>
date Mon, 21 Nov 2011 19:46:04 +0100
parents bccc91a65536
children e9f58d024c3c
line wrap: on
line diff
--- a/configure.ac	Mon Nov 21 09:26:45 2011 -0500
+++ b/configure.ac	Mon Nov 21 19:46:04 2011 +0100
@@ -5375,12 +5375,6 @@
 dnl .gdbinit is now handled like xemacs.def or other src files, and
 dnl its source is in src/.gdbinit.in.in.
 
-dnl Create a .dbxrc useful for debugging XEmacs
-if test -f "$srcdir/etc/dbxrc.in"; then
-  test "$verbose" = "yes" && echo "creating src/.dbxrc"
-  echo ". $srcdir/etc/dbxrc" > "$srcdir/src/.dbxrc"
-fi
-
 dnl Create a useful TAGS file
 if test -f "$srcdir/TAGS" -a ! -f "TAGS"; then
   test "$verbose" = "yes" && echo "creating TAGS"
@@ -6009,9 +6003,6 @@
     mv -f Makefile.new $2
 ])dnl CPP_MAKEFILE
 
-dnl for creation of /etc/dbxrc
-XE_APPEND(etc, MAKE_SUBDIR)
-
 AC_CONFIG_COMMANDS([default],
 [for dir in . $MAKE_SUBDIR; do
   (
@@ -6030,9 +6021,9 @@
       MAKE_JUNK_C(.gdbinit.in)
       CPP_MAKEFILE(,.gdbinit)
     fi
-    if test -r "dbxrc.in"; then
-      MAKE_JUNK_C(dbxrc.in)
-      CPP_MAKEFILE(,dbxrc)
+    if test -r ".dbxrc.in"; then
+      MAKE_JUNK_C(.dbxrc.in)
+      CPP_MAKEFILE(,.dbxrc)
     fi
     if test -r "xemacs.def.in"; then
 dnl #### We should be using MAKE_JUNK_C instead of the next two lines.