diff configure.in @ 185:3d6bfa290dbd r20-3b19

Import from CVS: tag r20-3b19
author cvs
date Mon, 13 Aug 2007 09:55:28 +0200
parents e121b013d1f0
children b405438285a2
line wrap: on
line diff
--- a/configure.in	Mon Aug 13 09:54:24 2007 +0200
+++ b/configure.in	Mon Aug 13 09:55:28 2007 +0200
@@ -257,6 +257,8 @@
 x_includes=NONE
 x_libraries=NONE
 CDPATH=.; export CDPATH
+dnl this will serve for testing if a default value sould be given
+package_path=NONE
 
 dnl Allow this script to work with zsh, by setting sh emulation options
 if test -n "$ZSH_VERSION"; then
@@ -279,8 +281,6 @@
 sharedstatedir='${prefix}/com'
 localstatedir='${prefix}/var'
 libdir='${{exec_prefix}}/lib'
-dnl The following gives NONE/lib/xemacs/packages as the first package
-dnl package_path=${prefix}/lib/xemacs/packages:~/.xemacs
 includedir='${prefix}/include'
 oldincludedir='/usr/include'
 infodir='${prefix}/info'
@@ -489,6 +489,9 @@
 --mail-locking=TYPE (*)	Specify the locking to be used by movemail to prevent
 			concurrent updates of mail spool files. Valid types
 			are \`lockf', \`flock', and \`file'.
+--package-path=PATH     A list of blank separated directories for finding 
+                        packages to dump with xemacs.
+			Defaults to \`$prefix/lib/xemacs/packages ~/.xemacs'
 
 Internationalization options:
 
@@ -2361,9 +2364,11 @@
   dnl autodetect -lXmu
   test -z "$with_xmu" && { AC_CHECK_LIB(Xmu, XmuReadBitmapDataFromFile,
                            with_xmu=yes, with_xmu=no) }
-  if test "$with_xmu" = "no"
-  then XE_ADD_OBJS(xmu.o)
-  else XE_PREPEND(-lXmu, libs_x)
+  if test "$with_xmu" = "no"; then
+    XE_ADD_OBJS(xmu.o)
+  else 
+    XE_PREPEND(-lXmu, libs_x)
+    AC_DEFINE(HAVE_XMU)
   fi
 
   dnl Autodetect -lXbsd
@@ -3368,11 +3373,13 @@
 AC_SUBST(dynodump_arch)
 
 
+dnl if --package-path wasn't passed to configure, give the default value
+if test "x${package_path}" = "xNONE" ; then
+	package_path="${prefix}/lib/xemacs/packages:~/.xemacs"
+fi
 dnl change blanks to colons in package path, and make available to config.h
-if test -n "$package_path"; then
-  package_path=`echo $package_path | sed 'y/ /:/'`
-  AC_DEFINE_UNQUOTED(PACKAGE_PATH, "$package_path")
-fi
+package_path=`echo $package_path | sed 'y/ /:/'`
+AC_DEFINE_UNQUOTED(PACKAGE_PATH, "$package_path")
 
 AC_DEFINE_UNQUOTED(EMACS_CONFIGURATION, "$canonical")
 AC_DEFINE_UNQUOTED(EMACS_CONFIG_OPTIONS, "${ac_configure_args}")