diff configure.ac @ 5748:3ccb4aaf91c7

* configure.ac (makeinfo): Use basic regexp. Avoid autoconf errors on empty version strings. Report version found if insufficient. Lightly tested.
author Stephen J. Turnbull <stephen@xemacs.org>
date Sun, 28 Jul 2013 02:46:02 +0900
parents 9c17f7be0b92
children a9fd35f939a5
line wrap: on
line diff
--- a/configure.ac	Wed Jul 10 14:32:02 2013 +0100
+++ b/configure.ac	Sun Jul 28 02:46:02 2013 +0900
@@ -2590,10 +2590,10 @@
 AC_MSG_CHECKING([for makeinfo >= 4.12])
 MAKEINFO=
 for prog in `which -a makeinfo`; do
-  mi_verstr=[`$prog --version | sed -rn '1s/.*+[[:blank:]]([^[:blank:]]+)$/\1/p'`]
+  mi_verstr=[`$prog --version | sed -n '1s/^.* \([0-9][0-9]*\.[0-9][0-9]*\)$/\1/p'`]
   mi_major=`echo $mi_verstr | cut -d. -f1`
   mi_minor=`echo $mi_verstr | cut -d. -f2`
-  if test $mi_major -gt 4 || ( test $mi_major -eq 4 && test $mi_minor -gt 11 );
+  if test "$mi_major" -gt 4 || ( test "$mi_major" -eq 4 && test "$mi_minor" -gt 11 );
   then
     MAKEINFO=$prog
     break
@@ -2601,7 +2601,7 @@
 done
 if test -z $MAKEINFO; then
   AC_MSG_RESULT([no])
-  AC_MSG_WARN([Makeinfo 4.12 or later required to build info files.])
+  AC_MSG_WARN([Found Makeinfo $mi_verstr.  4.12 or later required.])
 else
   AC_MSG_RESULT([yes])
 fi