diff configure.ac @ 4939:349f01075eb7

build fixes for gdbinit and config-dependent elc files -------------------- ChangeLog entries follow: -------------------- ChangeLog addition: 2010-01-20 Ben Wing <ben@xemacs.org> * Makefile.in.in: * Makefile.in.in (GENERATED_HEADERS): * Makefile.in.in (.PHONY): * Makefile.in.in (src/.gdbinit): * configure: * configure.ac (TAB): etc/gdbinit.in has been moved to src/.gdbinit.in.in. Reflect this -- generate src/.gdbinit.in from src/.gdbinit.in.in, and use the normal mechanism for doing so instead of copying it specially. Add target for `config-changed' and pass down to `src'. Move some PHONY declarations to just before the actual targets. src/ChangeLog addition: 2010-01-20 Ben Wing <ben@xemacs.org> * .gdbinit.in.in: Moved here from etc/.gdbinit.in. Put @srcdir@ in various places rather than just `..' whenever Makefile.in.in does so. Fixes various strange crashes and errors than occur when using `..'. * Makefile.in.in (config-changed): Add target, useful when building both Unicode-internal and old-Mule workspaces using --srcdir and don't run configure before switching from one to the other.
author Ben Wing <ben@xemacs.org>
date Wed, 20 Jan 2010 19:48:26 -0600
parents 8b63e21b0436
children 6af9b2e79451
line wrap: on
line diff
--- a/configure.ac	Tue Jan 19 11:25:37 2010 -0600
+++ b/configure.ac	Wed Jan 20 19:48:26 2010 -0600
@@ -5258,7 +5258,7 @@
 
 dnl Compute lists of Makefiles and subdirs
 AC_SUBST(SRC_SUBDIR_DEPS)
-internal_makefile_list="Makefile.in"
+internal_makefile_list="Makefile.in src/.gdbinit.in"
 SUBDIR_MAKEFILES=''
 test -d lock || mkdir lock
 for dir in $MAKE_SUBDIR; do
@@ -5308,11 +5308,8 @@
 
 dnl Unlike TAGS, debugger init files depend on config.h.
 dnl Regenerate them locally on every configure.
-dnl Create a .gdbinit useful for debugging XEmacs
-if test -f "$srcdir/etc/gdbinit.in"; then
-  test "$verbose" = "yes" && echo "creating src/.gdbinit.in"
-  cp $srcdir/etc/gdbinit.in src/.gdbinit.in
-fi
+dnl .gdbinit is now handled like xemacs.def or other src files, and
+dnl its source is in src/.gdbinit.in.in.
 
 dnl Create a .dbxrc useful for debugging XEmacs
 if test -f "$srcdir/etc/dbxrc.in"; then