diff modules/sample/external/configure.ac @ 996:25e260cb7994

[xemacs-hg @ 2002-09-10 15:27:02 by james] Enable unloading of dynamic modules. Create the first two internal XEmacs modules: LDAP and postgreSQL. Update the sample directory to contain a sample internal XEmacs module and a sample external XEmacs module. Improve support for autoloading modules. Make internal module code compile into the XEmacs binary if XEmacs is configured without module support. Make the internal module directories self-contained so that they can be distributed separately from XEmacs.
author james
date Tue, 10 Sep 2002 15:27:39 +0000
parents
children dce479915b74
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/modules/sample/external/configure.ac	Tue Sep 10 15:27:39 2002 +0000
@@ -0,0 +1,26 @@
+# Process this file with autoconf to produce a configure script.
+AC_INIT([Sample module], [1.0], [xemacs-beta@xemacs.org])
+AC_PREREQ(2.53)
+AC_REVISION($Revision: 1.1 $)
+AC_COPYRIGHT([Configuration script for the sample module.
+Copyright (C) 2002 Jerry James.
+
+This file is not part of XEmacs.])
+
+AC_CONFIG_SRCDIR([sample.c])
+AC_PROG_CC
+AC_PROG_INSTALL
+AC_SUBST(CFLAGS)
+AC_SUBST(LDFLAGS)
+
+# Find ELLCC
+AC_ARG_VAR([ELLCC], [The path to the ellcc module compiler])
+AC_PATH_PROG([ELLCC], [ellcc], ["FAIL"])
+AS_IF([test "$ELLCC" = "FAIL"], [AS_ERROR([Cannot find ellcc])])
+AC_SUBST(ELLCC)
+
+# Insert autoconf macros here to find the headers, libraries, other
+# programs, etc. needed by your module.
+
+AC_CONFIG_FILES([Makefile.in Makefile])
+AC_OUTPUT