diff configure.in @ 460:223736d75acb r21-2-45

Import from CVS: tag r21-2-45
author cvs
date Mon, 13 Aug 2007 11:43:24 +0200
parents c33ae14dd6d0
children 0784d089fdc9
line wrap: on
line diff
--- a/configure.in	Mon Aug 13 11:42:27 2007 +0200
+++ b/configure.in	Mon Aug 13 11:43:24 2007 +0200
@@ -3,10 +3,11 @@
 [#### Configuration script for XEmacs.  Largely divergent from FSF.
 #### Guess values for system-dependent variables and create Makefiles.
 #### Generated automatically using autoconf version] AC_ACVERSION [
-#### Copyright (C) 1992, 93, 94, 95, 96 Free Software Foundation, Inc.
+#### Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000 Free Software Foundation, Inc.
 #### Copyright (C) 1993-1995 Board of Trustees, University of Illinois.
 #### Copyright (C) 1996, 1997 Sun Microsystems, Inc.
 #### Copyright (C) 1995, 1996 Ben Wing.
+#### Copyright (C) 2000, 2001 Martin Buchholz.
 #### Copyright (C) 1998, 1999 J. Kean Johnston.
 
 ### Don't edit this script!
@@ -1507,18 +1508,7 @@
       *-bsdi3* )		opsys=bsdos3 ;;
       *-bsdi2.1* )		opsys=bsdos2-1 ;;
       *-bsdi2* )		opsys=bsdos2 ;;
-      *-sco3.2v5* )		opsys=sco5 ;
-	dnl This is a pain.  Like the current USL cc, SCO cc -E
-	dnl tokenizes as it preprocesses, making configure very
-	dnl unhappy.  Unfortunately, /lib/cpp does not understand
-	dnl flags like "-b elf", so we have to cheat in order to
-	dnl pick up the right defines for UNEXEC from the s-file.
-	dnl 01/05/95 robertl@dgii.com
-	if test "$dynamic" = "yes" ; then
-		NON_GNU_CPP="/lib/cpp -D_XOPEN_SOURCE -D_SCO_ELF"  ;
-	else
-		NON_GNU_CPP="/lib/cpp -D_XOPEN_SOURCE"  ;
-	fi ;;
+      *-sco3.2v5* )		opsys=sco5 ;;
       *-sysv5* )		opsys=sco7 ;;
       *-386bsd* )	        opsys=386bsd ;;
       *-freebsd* )		opsys=freebsd ;;
@@ -2254,9 +2244,6 @@
 ])dnl
 XE_COMPUTE_RUNPATH()
 
-dnl JKJ REMOVEME
-dnl XE_SHLIB_STUFF
-
 dnl -----------------------------------
 dnl Do some misc autoconf-special tests
 dnl -----------------------------------
@@ -2343,31 +2330,29 @@
   sys/un.h dnl
   ulimit.h dnl
   unistd.h dnl
-  utime.h dnl
 )
 AC_HEADER_SYS_WAIT
 AC_HEADER_STDC
 AC_HEADER_TIME
 AC_DECL_SYS_SIGLIST
 
-dnl Some systems have utime.h but do not declare the struct anyplace.
-AC_MSG_CHECKING(for struct utimbuf)
-AC_TRY_COMPILE([#ifdef TIME_WITH_SYS_TIME
-#include <sys/time.h>
-#include <time.h>
-#else
-#ifdef HAVE_SYS_TIME_H
-#include <sys/time.h>
-#else
-#include <time.h>
-#endif
-#endif
-#ifdef HAVE_UTIME_H
-#include <utime.h>
-#endif], [static struct utimbuf x; x.actime = x.modtime;],
+
+dnl ----------------------------------------------------------------
+dnl Checking for utime() or utimes().
+dnl We prefer utime, since it is more standard.
+dnl Some systems have utime.h but do not declare the struct anyplace,
+dnl so we use a more sophisticated test for utime than AC_CHECK_FUNCS.
+dnl ----------------------------------------------------------------
+AC_MSG_CHECKING(for utime)
+AC_TRY_COMPILE([#include <sys/types.h>
+#include <utime.h>],
+[struct utimbuf x; x.actime = x.modtime = 0; utime ("/", &x);],
   [AC_MSG_RESULT(yes)
-   AC_DEFINE(HAVE_STRUCT_UTIMBUF)],
-  AC_MSG_RESULT(no))
+   AC_DEFINE(HAVE_UTIME)],
+  [AC_MSG_RESULT(no)
+   dnl We don't have utime(); how about utimes()?
+   AC_CHECK_FUNCS(utimes)])
+
 
 dnl checks for typedefs
 AC_TYPE_SIGNAL
@@ -3072,8 +3057,8 @@
     AC_MSG_RESULT($with_xpm)
   fi
   if test "$with_xpm" = "yes"; then
-    dnl #### This code assumes that if AC_CHECK_LIB fails, 
-    dnl #### then it will succeed if FOR_MSW is defined, 
+    dnl #### This code assumes that if AC_CHECK_LIB fails,
+    dnl #### then it will succeed if FOR_MSW is defined,
     dnl #### but doesn't actually verify this assumption.
     AC_DEFINE(HAVE_XPM)
     XE_PREPEND(-lXpm, libs_x)
@@ -3559,7 +3544,7 @@
   XE_COMPUTE_RUNPATH()
 fi
 
-AC_CHECK_FUNCS(cbrt closedir dup2 eaccess fmod fpathconf frexp ftime getaddrinfo gethostname getnameinfo getpagesize gettimeofday getcwd getwd logb lrand48 matherr mkdir mktime perror poll random rename res_init rint rmdir select setitimer setpgid setlocale setsid sigblock sighold sigprocmask snprintf stpcpy strerror tzset ulimit usleep utimes waitpid vsnprintf fsync ftruncate umask)
+AC_CHECK_FUNCS(cbrt closedir dup2 eaccess fmod fpathconf frexp ftime getaddrinfo gethostname getnameinfo getpagesize gettimeofday getcwd getwd logb lrand48 matherr mkdir mktime perror poll random rename res_init rint rmdir select setitimer setpgid setlocale setsid sigblock sighold sigprocmask snprintf stpcpy strerror tzset ulimit usleep waitpid vsnprintf fsync ftruncate umask)
 
 dnl ----------------------------------------------------------------
 dnl Check for PTY support functions.