diff configure.in @ 369:1d62742628b6 r21-1-14

Import from CVS: tag r21-1-14
author cvs
date Mon, 13 Aug 2007 11:01:51 +0200
parents a4f53d9b3154
children cc15677e0335
line wrap: on
line diff
--- a/configure.in	Mon Aug 13 11:01:11 2007 +0200
+++ b/configure.in	Mon Aug 13 11:01:51 2007 +0200
@@ -3128,7 +3128,15 @@
 # Check for UNIX98 PTYs.
 # getpt is a glibc addition which emulates the master device on
 # systems without kernel support.
-AC_CHECK_FUNCS(grantpt unlockpt getpt ptsname)
+AC_CHECK_FUNCS(grantpt unlockpt getpt ptsname killpg)
+
+dnl Check for STREAM support functions.
+dnl Confusingly, "str" means both "string" and "SysV Streams".
+AC_CHECK_HEADERS(stropts.h)
+if test "$ac_cv_header_stropts_h" = "yes"; then
+  AC_CHECK_FUNCS(isastream)
+  AC_CHECK_HEADERS(strtio.h) dnl TIOCSIGNAL
+fi
 
 dnl realpath is buggy on linux, decosf and aix4