diff configure.ac @ 4708:1cecc3e9f0a0

Use giflib or libungif to provide GIF support, instead of using internal routines. Delete internal GIF support code with no stated license. Fix up a number of references in the documentation to GIF support. See discussion on xemacs-beta: <87iqg4vg9t.fsf@uwakimon.sk.tsukuba.ac.jp>.
author Jerry James <james@xemacs.org>
date Mon, 05 Oct 2009 10:11:59 -0600
parents 0e1461b592ce
children 80d74fed5399
line wrap: on
line diff
--- a/configure.ac	Sat Oct 03 14:22:08 2009 +0100
+++ b/configure.ac	Mon Oct 05 10:11:59 2009 -0600
@@ -802,7 +802,7 @@
                         Requires the compface package.]),
 	[], [])
 XE_MERGED_ARG([gif],
-	AS_HELP_STRING([--with-gif],[Compile without the (builtin) support for GIF images.]),
+	AS_HELP_STRING([--with-gif],[Compile with support for GIF images.]),
 	[], [])
 dnl
 XE_HELP_SUBSECTION([Sound options])
@@ -4124,11 +4124,19 @@
     XE_PREPEND(-lcompface, libs_x)
   fi
 
-  dnl For a brief period we had the GIF code split out into a separate library,
-  dnl but patent problems, etc. sort of squashed that idea.
-  dnl We default to building with builtin GIF decoding
+  dnl autodetect GIF
+  test -z "$with_gif" && { AC_CHECK_HEADER(gif_lib.h, , with_gif=no) }
   if test "$with_gif" != "no"; then
     with_gif="yes"
+    dnl Versions of libgif and libungif prior to the introduction of
+    dnl EGifPutExtensionLast caused Emacs crashes.  We'll require that
+    dnl function, too, in hopes that we can avoid similar crashes.
+    AC_CHECK_LIB(gif, EGifPutExtensionLast,
+      [XE_PREPEND(-lgif, libs_x)],
+      [AC_CHECK_LIB(ungif, EGifPutExtensionLast,
+        [XE_PREPEND(-lungif, libs_x)], with_gif=no)])
+  fi
+  if test "$with_gif" != "no"; then
     AC_DEFINE(HAVE_GIF)
   fi
 
@@ -6103,7 +6111,7 @@
 
 echo "
 Images:"
-test "$with_gif" = yes && echo "  Compiling in support for GIF  images (builtin)."
+test "$with_gif" = yes && echo "  Compiling in support for GIF images."
 if test "$with_xpm" = yes; then
   echo "  Compiling in support for XPM  images."
 elif test "$with_x11" = yes; then