diff configure.in @ 38:1a767b41a199 r19-15b102

Import from CVS: tag r19-15b102
author cvs
date Mon, 13 Aug 2007 08:54:01 +0200
parents e04119814345
children 8d2a9b52c682
line wrap: on
line diff
--- a/configure.in	Mon Aug 13 08:53:41 2007 +0200
+++ b/configure.in	Mon Aug 13 08:54:01 2007 +0200
@@ -3376,6 +3376,24 @@
       test -n "${ac_have_lib}" && with_xmu="yes"
       # end expansion of ac_have_library
     fi
+    # Sparc/Linux test - fp
+    if test "${with_xmu}" != "yes" -a  ${machine} = sparc -a ${opsys} = linux; then
+      # begin expansion of ac_have_library
+      ac_save_LIBS="${LIBS}"
+      LIBS="${LIBS} -lXmu -lXt -lXext -lX11 -lm -lICE -lSM"
+      ac_have_lib=""
+      cat > conftest.${ac_ext} <<EOF
+int main() { return 0; }
+EOF
+      if eval $ac_compile; then
+        rm -rf conftest*
+        ac_have_lib="1"
+      fi
+      rm -f conftest*
+      LIBS="${ac_save_LIBS}"
+      test -n "${ac_have_lib}" && with_xmu="yes"
+      # end expansion of ac_have_library
+    fi
     # On UnixWare 2.1 we must kludge harder to try to detect Xmu
     # Upgrade to autoconf 2 and use ac_check_lib - mrb
     if test "${with_xmu}" != "yes" && test -f "/.UpgradeVer2.1" ; then