diff configure.in @ 321:19dcec799385 r21-0-58

Import from CVS: tag r21-0-58
author cvs
date Mon, 13 Aug 2007 10:46:44 +0200
parents afd57c14dfc8
children 03446687b7cc
line wrap: on
line diff
--- a/configure.in	Mon Aug 13 10:46:01 2007 +0200
+++ b/configure.in	Mon Aug 13 10:46:44 2007 +0200
@@ -1325,6 +1325,13 @@
     NON_GNU_CPP=/usr/ccs/lib/cpp
   ;;
 
+  dnl NEC
+  mips-nec-sysv*)
+    machine=mips-nec
+    NON_GNU_CC=/usr/ccs/bin/cc
+    NON_GNU_CPP=/usr/ccs/lib/cpp
+  ;;
+
   dnl Silicon Graphics machines
   dnl Iris 2500 and Iris 2500 Turbo (aka the Iris 3030)
   m68*-sgi-iris3.5* ) machine=irist opsys=iris3-5 ;;
@@ -1482,6 +1489,9 @@
   dnl Linux/68k
   m68k-*-linux* ) machine=m68k opsys=linux ;;
 
+  dnl Linux/arm
+  arm-*-linux* ) machine=arm opsys=linux ;;
+
 esac
 
 if test -z "$machine" -o -z "$opsys"; then
@@ -2081,7 +2091,7 @@
 
 dnl checks for header files
 AC_CHECK_HEADERS(mach/mach.h sys/stropts.h sys/timeb.h sys/time.h unistd.h)
-AC_CHECK_HEADERS(utime.h locale.h libgen.h fcntl.h ulimit.h cygwin32/version.h)
+AC_CHECK_HEADERS(utime.h locale.h libgen.h fcntl.h ulimit.h cygwin/version.h)
 AC_CHECK_HEADERS(linux/version.h kstat.h sys/pstat.h inttypes.h sys/un.h a.out.h)
 AC_HEADER_SYS_WAIT
 AC_HEADER_STDC
@@ -2442,6 +2452,7 @@
     AC_DEFINE(HAVE_MS_WINDOWS)
     install_pp="$blddir/lib-src/installexe.sh"
     XE_APPEND(-lshell32 -lgdi32 -luser32 -lcomctl32, libs_system)
+    test "$with_dragndrop" != no && XE_APPEND(msw, dragndrop_proto)
     if test "$window_system" != x11; then
  	window_system=msw
 	test "$with_scrollbars" != "no" && with_scrollbars=msw \
@@ -3002,14 +3013,19 @@
     test "$ac_cv_func_crypt" != "yes" && { AC_CHECK_LIB(crypt, crypt) }
   fi
   dnl Back to our regularly scheduled wnn hunting
-  test -z "$with_wnn" && { AC_CHECK_LIB(wnn,jl_dic_list_e,[:],with_wnn=no) }
+  if test -z "$with_wnn" -o "$with_wnn" = "yes"; then
+    AC_CHECK_LIB(wnn,jl_dic_list_e,libwnn=wnn,
+      AC_CHECK_LIB(wnn4,jl_dic_list_e,libwnn=wnn4,
+	AC_CHECK_LIB(wnn6,jl_dic_list_e,libwnn=wnn6,
+	  AC_CHECK_LIB(wnn6_fromsrc,dic_list_e,libwnn=wnn6_fromsrc,with_wnn=no))))
+  fi
   test -z "$with_wnn" && with_wnn=yes
   if test "$with_wnn" = "yes"; then
     AC_DEFINE(HAVE_WNN)
-    XE_PREPEND(-lwnn, libs_x)
+    XE_PREPEND(-l$libwnn, libs_x)
     XE_ADD_OBJS(mule-wnnfns.o)
     if test "$with_wnn6" != "no"; then
-      AC_CHECK_LIB(wnn, jl_fi_dic_list, with_wnn6=yes)
+      AC_CHECK_LIB($libwnn, jl_fi_dic_list, with_wnn6=yes)
       test "$with_wnn6" = "yes" && AC_DEFINE(WNN6)
     fi
   fi
@@ -3067,11 +3083,15 @@
 dnl For example, call realpath on a file thirty-five or so directories deep
 dnl and you get ELOOP even if no symlinks at all are involved.
 dnl Reports as of 11/1997 indicate BSDi has problems too.
+dnl The realpath() in UnixWare2.1.3 could not get any pathname fragment in error condition.
 case "$opsys" in
   linuxaout* | bsdos3* | freebsd* | decosf4-0* | aix4* ) XE_ADD_OBJS(realpath.o) ;;
   * )
-    AC_CHECK_FUNCS(realpath)
-    test "$ac_cv_func_realpath" != "yes" && XE_ADD_OBJS(realpath.o) ;;
+    case "$canonical" in
+      *-*-sysv4.2uw2* ) XE_ADD_OBJS(realpath.o) ;;
+      * ) AC_CHECK_FUNCS(realpath)
+	  test "$ac_cv_func_realpath" != "yes" && XE_ADD_OBJS(realpath.o) ;;
+    esac ;;
 esac
 
 dnl If netdb.h does not declare h_errno, we must declare it by hand.
@@ -3557,6 +3577,9 @@
   XE_PREPEND(-Bstatic -lut -Bdynamic, LIBS)
 fi
 
+dnl cygwin can't cope with dlfcn at the moment
+test -z "$with_shlib" && test "$opsys $machine" = "cygwin32 intel386" && with_shlib=no
+
 dnl autodetect dll support
 AC_CHECK_HEADERS(dlfcn.h, have_dlfcn=yes)
 test -z "$with_shlib" && test ! -z "$have_dlfcn" && { AC_CHECK_LIB(dl,  dlopen,   [ AC_DEFINE(HAVE_DLOPEN) DLL_LIB=dl;  with_shlib=yes]) }