diff configure.in @ 28:1917ad0d78d7 r19-15b97

Import from CVS: tag r19-15b97
author cvs
date Mon, 13 Aug 2007 08:51:55 +0200
parents 441bb1e64a06
children ec9a17fef872
line wrap: on
line diff
--- a/configure.in	Mon Aug 13 08:51:34 2007 +0200
+++ b/configure.in	Mon Aug 13 08:51:55 2007 +0200
@@ -918,7 +918,7 @@
           eval "${opt}=\"${val}\""
         ;;
 
-        ## Has the user specified a value for PURESIZE?
+        ## Has the user specified a value for RAW_PURESIZE?
 	"puresize" )
 	  ## If the value was omitted, get it from the next argument.
 	  if [ "${valomitted}" = "yes" ]; then
@@ -1444,7 +1444,7 @@
 #### have stuck the source on a read-only partition.  Instead we'll
 #### create it as an actual directory later on if it doesn't already
 #### exist.
-for dir in etc man info site-lisp
+for dir in lisp etc man info site-lisp
 do
   if [ ! -d $dir ]; then
     echo Making symbolic link to ${srcdir}/$dir
@@ -1452,20 +1452,6 @@
   fi
 done
 
-# lisp/ is special
-if [ ! -d lisp ]; then
-	mkdir lisp
-	echo Making symbolic links to lisp libraries
-	${LN_S} ${srcdir}/lisp/* ./lisp
-	rm -f ./lisp/*.el ./lisp/site-packages
-	cp ${srcdir}/lisp/*.el lisp
-	if [ -f ${srcdir}/lisp/site-packages ]; then
-		cp ${srcdir}/lisp/site-packages lisp
-	fi
-fi
-
-cp ${srcdir}/lisp/version.el lisp
-
 #### Make srcdir absolute, if it isn't already.  It's important to
 #### avoid running the path through pwd unnecessary, since pwd can
 #### give you automounter prefixes, which can go away.
@@ -4101,7 +4087,7 @@
 # autodetection.
 
 if [ x"${puresize}" != x ] ; then
-  ] AC_DEFINE_UNQUOTED(PURESIZE,	${puresize}) [
+  ] AC_DEFINE_UNQUOTED(RAW_PURESIZE,	${puresize}) [
 fi
 if [ "${HAVE_X_WINDOWS}" = "yes" ] ; then
   ] AC_DEFINE(HAVE_X_WINDOWS) [