diff modules/postgresql/configure.ac @ 1111:184461bc8de4

[xemacs-hg @ 2002-11-18 06:52:23 by ben] warning fixes, etc. * s/cygwin32.h: -fvtable-thunks is obsolete in GCC 3 and generates warnings. * s/mingw32.h: * s/windowsnt.h: Comment fixes. * emodules.h: Fix warnings from redefining symbols. * eval.c: Fix C++ errors -- no automatic casting between function pointers and void *, function declarations inside of functions not allowed. * event-Xt.c (emacs_Xt_enqueue_focus_event): Warning fixes. * fileio.c (Ffile_truename): Warning fixes. Use LOCAL_TO_WIN32_FILE_FORMAT rather than duplicating it. * glyphs-x.c: Fix style. * intl-auto-encap-win32.c: * intl-auto-encap-win32.h: * intl-encap-win32.c: * intl-encap-win32.c (qxeRegConnectRegistry): * syswindows.h (RegConnectRegistry): DdeCreateStringHandle needs to be manual due to new Cygwin bug. * intl-win32.c: wcslen/wcscmp don't seem to exist under G++ 3, Cygwin. * lisp.h: * lisp-union.h: * lisp-disunion.h: * process-unix.c (unix_send_process): Ugh, C needs volatile and C++ must not have volatile. Remove previous volatile hacks, which don't seem to be working any more. * sheap.c (STATIC_HEAP_SLOP): Try to get a working Cygwin build with old unexec. * sheap.c (more_static_core): No NL's in literals allowed. * symbols.c (Fset): Fix C++ errors. * syswindows.h: Fix Cygwin complaints now that some missing structs have been added. aclocal.m4: Disable shared library modules under Cygwin for the moment, since we need some more tricky coding done and I don't have the time right now. configure.in, configure.usage: code-files.el, loadhist.el: Fix warnings. package-get.el: Fix warnings. NOTE: This was already fixed awhile ago, but reverted by Steve Y. Please be careful. postgresql/Makefile.in.in: Removed. Move common stuff into modues/common/Makefile.common. (Also add extraclean target and a couple of other fixes in that file.) postgresql/configure.ac: Extract out common configure stuff into modules/common/configure-{pre,post}.ac. postgresql/postgresql.c: Fix warning. ldap/Makefile.in.in: Removed. Move common stuff into modues/common/Makefile.common. (Also add extraclean target and a couple of other fixes in that file.) ldap/configure.ac: Extract out common configure stuff into modules/common/configure-{pre,post}.ac. common/Makefile.common: Common stuff is here.
author ben
date Mon, 18 Nov 2002 06:53:08 +0000
parents 25e260cb7994
children 56b64a055043
line wrap: on
line diff
--- a/modules/postgresql/configure.ac	Sun Nov 17 22:53:08 2002 +0000
+++ b/modules/postgresql/configure.ac	Mon Nov 18 06:53:08 2002 +0000
@@ -2,7 +2,7 @@
 # This is only used for independent module building.
 AC_INIT([PostgreSQL module], [1.0], [xemacs-beta@xemacs.org])
 AC_PREREQ(2.53)
-AC_REVISION($Revision: 1.1 $)
+AC_REVISION($Revision: 1.2 $)
 AC_COPYRIGHT([Configuration script for the PostgreSQL module.
 Copyright (C) 2002 Jerry James.
 
@@ -24,15 +24,8 @@
 02111-1307, USA.])
 
 AC_CONFIG_SRCDIR([postgresql.c])
-AC_PROG_CC
-AC_PROG_INSTALL
-AC_SUBST(CFLAGS)
-AC_SUBST(LDFLAGS)
 
-# Find ELLCC
-AC_ARG_VAR([ELLCC], [The path to the ellcc module compiler])
-AC_PATH_PROG([ELLCC], [ellcc], ["FAIL"])
-AS_IF([test "$ELLCC" = "FAIL"], [AS_ERROR([Cannot find ellcc])])
+m4_include([../common/configure-pre.ac])
 
 dnl On many Linux systems, PostgreSQL is packaged to be installed in /usr;
 dnl in this case, configure will easily detect it there.
@@ -58,15 +51,4 @@
              AC_DEFINE(HAVE_POSTGRESQLV7)])
 AC_SUBST(postgresql_libs, "$LIBS")
 
-# This part should appear unchanged in every module configure.ac
-AC_SUBST(PROGNAME, "module")
-AC_SUBST(MOD_CC, "@ELLCC@")
-AC_SUBST(MODARCHDIR, "\$(shell @ELLCC@ --mod-archdir)")
-AC_SUBST(MAKE_DOCFILE, "\$(MODARCHDIR)/make-docfile")
-AC_SUBST(MODCFLAGS, "\$(CFLAGS) --mode=compile --mod-output=\$@ -I\$(MODARCHDIR)/include")
-AC_SUBST(INSTALLPATH, "\$(shell @ELLCC@ --mod-site-location)")
-AC_SUBST(MOD_INSTALL_PROGRAM, "@INSTALL_PROGRAM@")
-AC_SUBST(OBJECT_TO_BUILD, "\$(MODNAME).ell")
-
-AC_CONFIG_FILES([Makefile.in Makefile])
-AC_OUTPUT
+m4_include([../common/configure-post.ac])