diff configure.ac @ 3354:15fb91e3a115

[xemacs-hg @ 2006-04-23 16:11:16 by stephent] Xft/fontconfig refactoring, Part I. <87hd4ks29d.fsf@tleepslib.sk.tsukuba.ac.jp>
author stephent
date Sun, 23 Apr 2006 16:11:34 +0000
parents 83ea3a38afe7
children a1e20876b806
line wrap: on
line diff
--- a/configure.ac	Sat Apr 22 21:51:52 2006 +0000
+++ b/configure.ac	Sun Apr 23 16:11:34 2006 +0000
@@ -669,6 +669,11 @@
 	[AC_DEFINE(INFOPATH_USER_DEFINED)], [])
 dnl
 XE_HELP_SUBSECTION([Window-system options])
+dnl Enable when fontconfig support is factored out of Xft.
+dnl XE_MERGED_ARG([fontconfig],
+dnl	AS_HELP_STRING([--with-fontconfig],
+dnl		       [Use fontconfig library to configure fonts.],
+dnl		       [],[])
 dnl if you change defaults, make sure to fix arg 6 of the OPTION_HELP macro.
 XE_COMPLEX_ARG([xft],
 	[XE_COMPLEX_OPTION_HELP_STRING([--with-xft],
@@ -3463,6 +3468,9 @@
           [XE_DIE(["Unable to find libfontconfig for --with-xft"])])
       AC_CHECK_LIB(Xft, XftFontOpen, XE_PREPEND(-lXft, libs_x),
           [XE_DIE(["Unable to find libXft for --with-xft"])])
+      dnl #### detect fontconfig properly!!!!
+      with_fontconfig=yes
+      AC_DEFINE(HAVE_FONTCONFIG)
       AC_DEFINE(USE_XFT)
       dnl Due to interactions with other libraries, must postpone AC_DEFINE
       dnl of USE_XFT_MENUBARS, USE_XFT_TABS, and USE_XFT_GAUGE.
@@ -5977,6 +5985,9 @@
   if test "$with_wmcommand" != no; then
     echo "    - Handling WM_COMMAND properly."
   fi
+  if test "$with_fontconfig" = "yes"; then
+    echo "    - Using fontconfig to manage fonts."
+  fi
   if test "$with_xft_emacs" = "yes"; then
     echo "    - Compiling in support for Xft antialiased fonts (EXPERIMENTAL)."
   fi