diff configure.in @ 2009:1388c8b3e663

[xemacs-hg @ 2004-04-13 04:23:49 by james] Kaarthik Sivakumar's change to check for libmp dependencies before checking whether it contains the move function.
author james
date Tue, 13 Apr 2004 04:23:50 +0000
parents 1ea9c87af805
children 193e76abdf0f
line wrap: on
line diff
--- a/configure.in	Mon Apr 12 21:50:51 2004 +0000
+++ b/configure.in	Tue Apr 13 04:23:50 2004 +0000
@@ -4891,23 +4891,26 @@
 elif test "$use_number_lib" = "mp"; then
   for library in "" "-lcrypto"; do
     AC_CHECK_HEADER(mp.h, [
-      AC_CHECK_LIB(mp, mp_mfree, have_mp_mfree=yes break, [
-	AC_CHECK_LIB(mp, mfree, have_mfree=yes break, , $library)],
+      AC_CHECK_LIB(mp, mp_mfree, have_mp_mfree=yes; break, [
+	AC_CHECK_LIB(mp, mfree, have_mfree=yes; break, , $library)],
 	$library)])
   done
   if test "$have_mp_mfree" = "yes"; then
     AC_DEFINE(MP_PREFIX)
     XE_APPEND(-lmp, LIBS)
+    if test "$library" != ""; then
+      XE_APPEND($library, LIBS)
+    fi
     AC_CHECK_FUNC(mp_move, [AC_DEFINE(HAVE_MP_MOVE)])
   elif test "$have_mfree" = "yes"; then
     XE_APPEND(-lmp, LIBS)
+    if test "$library" != ""; then
+      XE_APPEND($library, LIBS)
+    fi
     AC_CHECK_FUNC(move, [AC_DEFINE(HAVE_MP_MOVE)])
   else
     XE_DIE("Required MP numeric support cannot be provided.")
   fi
-  if test "$library" != ""; then
-    XE_APPEND($library, LIBS)
-  fi
   AC_DEFINE(WITH_NUMBER_TYPES)
   AC_DEFINE(WITH_MP)
 fi